summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b3bcbae6d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = neovim-ultisnips-opt-git
+ pkgdesc = The ultimate snippet solution for (neo)vim.
+ pkgver = 1511.ee31ea1
+ pkgrel = 1
+ url = https://github.com/sirver/ultisnips
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = neovim
+ depends = python
+ source = git+https://github.com/sirver/ultisnips.git
+ sha256sums = SKIP
+
+pkgname = neovim-ultisnips-opt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f82a22265d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=neovim-ultisnips-opt-git
+_pkgname=ultisnips
+pkgver=1511.ee31ea1
+pkgrel=1
+pkgdesc='The ultimate snippet solution for (neo)vim.'
+arch=('any')
+url="https://github.com/sirver/${_pkgname}"
+license=('GPL3')
+depends=('neovim' 'python')
+makedepends=('git')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" pythonx after doc ftdetect autoload ftplugin plugin syntax
+
+ find "${pkgdir}" -name '*.py' -exec python -mpy_compile {} +
+ find "${pkgdir}" -name '*.py' -exec python -O -mpy_compile {} +
+
+}