summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--zen-mode.install9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ab5a3b31ce4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-zen-mode-git
+ pkgdesc = Full-screen code editing
+ pkgver = r26.f1cc53d
+ pkgrel = 1
+ url = https://github.com/folke/zen-mode.nvim
+ install = zen-mode.install
+ arch = any
+ groups = neovim-plugins
+ license = unknown
+ makedepends = git
+ depends = neovim
+ optdepends = neovim-twilight
+ provides = neovim-zen-mode
+ conflicts = neovim-zen-mode
+ source = neovim-zen-mode-git::git+https://github.com/folke/zen-mode.nvim
+ md5sums = SKIP
+
+pkgname = neovim-zen-mode-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acb9ee70a8ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-zen-mode-git
+pkgver=r26.f1cc53d
+pkgrel=1
+pkgdesc="Full-screen code editing"
+arch=('any')
+url="https://github.com/folke/zen-mode.nvim"
+license=('unknown')
+groups=('neovim-plugins')
+depends=('neovim')
+optdepends=('neovim-twilight')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=zen-mode.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua plugin -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/zen-mode.install b/zen-mode.install
new file mode 100644
index 000000000000..9a17b96b2c97
--- /dev/null
+++ b/zen-mode.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-zen-mode-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}