summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD100
-rw-r--r--nerd-fonts-complete.links150
3 files changed, 83 insertions, 177 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db73b77269bd..44987d3eb57e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-complete
pkgdesc = collection of over 20 patched fonts (complete variant) for powerline, devicons, and vim-devicons: includes Droid Sans, Meslo, AnonymousPro, ProFont, Inconsolta, and many more
- pkgver = 1.0.0
- pkgrel = 3
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/ryanoasis/nerd-fonts
install = nerd-fonts-complete.install
arch = any
@@ -11,10 +11,8 @@ pkgbase = nerd-fonts-complete
depends = xorg-font-utils
conflicts = nerd-fonts-git
conflicts = nerd-fonts-complete-mono-glyphs
- source = nerd-fonts-complete.links
- source = https://github.com/ryanoasis/nerd-fonts/raw/v1.0.0/LICENSE
- sha256sums = 36916f6d9ce60a7fba173710127752f123cbbed484f07919d8ea3cf4e8b72da6
- sha256sums = 25f0b18305451ab7353c534098d9daf4051fbedfac6d5ef9be5de42e007e1c3f
+ source = nerd-fonts-complete-1.1.0.tar.gz::https://github.com/ryanoasis/nerd-fonts/archive/v1.1.0.tar.gz
+ sha256sums = ee7ae13f09ec576e2fb3da71b8aa217eae152a64e375697f16529b7182cedb27
pkgname = nerd-fonts-complete
diff --git a/PKGBUILD b/PKGBUILD
index 13809b2e8495..011a99bddcf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,91 @@
-# Maintainer: Super Bo <supernbo@gmail.com>
+# Maintainer: Super Bo <supernbo at gmail dot com>
+# Maintainer: glider <samtron1412 {at} gmail {dot} com>
pkgname=nerd-fonts-complete
-pkgver=1.0.0
-pkgrel=3
-pkgdesc="collection of over 20 patched fonts (complete variant) for powerline, devicons, and vim-devicons: includes Droid Sans, Meslo, AnonymousPro, ProFont, Inconsolta, and many more"
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="collection of over 20 patched fonts (complete variant) for \
+ powerline, devicons, and vim-devicons: includes Droid Sans, \
+ Meslo, AnonymousPro, ProFont, Inconsolta, and many more"
arch=('any')
-url='https://github.com/ryanoasis/nerd-fonts'
+url="https://github.com/ryanoasis/nerd-fonts"
license=('MIT')
depends=('fontconfig' 'xorg-font-utils')
makedepends=('wget')
-conflicts=(nerd-fonts-git nerd-fonts-complete-mono-glyphs)
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete-mono-glyphs')
install=$pkgname.install
-source=("$pkgname.links"
- "https://github.com/ryanoasis/nerd-fonts/raw/v1.0.0/LICENSE")
-sha256sums=(
- '36916f6d9ce60a7fba173710127752f123cbbed484f07919d8ea3cf4e8b72da6'
- '25f0b18305451ab7353c534098d9daf4051fbedfac6d5ef9be5de42e007e1c3f')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ryanoasis/nerd-fonts/archive/v$pkgver.tar.gz")
+sha256sums=('ee7ae13f09ec576e2fb3da71b8aa217eae152a64e375697f16529b7182cedb27')
prepare() {
- # Just download font file (complete version) from github repo because the whole repo is too big
- cd "${srcdir}"
- echo "Downloading fonts ...."
- wget -c --show-progress -i "${pkgname}.links"
+ extension="otf"
+ nerdfonts_dir="$srcdir/nerd-fonts-$pkgver/patched-fonts"
+ fonts_dir="\"$nerdfonts_dir\""
+ #
+ # Start constructing `find` expression
+ #
+ implode() {
+ # $1 is return variable name
+ # $2 is sep
+ # $3... are the elements to join
+ local retname=$1 sep=$2 ret=$3
+ shift 3 || shift $(($#))
+ printf -v "$retname" "%s" "$ret${@/#/$sep}"
+ }
+ find_include="-and -name '*Complete*'"
+ find_exclude=
+
+ # Exclude everything we didn’t include
+ exclude=("Font Awesome" "Font Linux" "Octicons" "Pomicons" "Nerd Font*Mono" "Windows Compatible")
+ for delete in "${include[@]}"; do
+ exclude=( "${exclude[@]/$delete}" )
+ done
+ # Delete empty elements
+ for i in "${!exclude[@]}"; do
+ [ "${exclude[$i]}" = '' ] && unset exclude[$i]
+ done
+ if [ ! -z "${exclude[*]}" ]; then
+ implode find_exclude "*' -and \! -name '*" "${exclude[@]}"
+ find_exclude="-and \! -name '*${find_exclude}*'"
+ fi
+
+ # Put it all together into the find command we want
+ find_command="find $fonts_dir \( \( -name '*.[o,t]tf' -or -name '*.pcf.gz' \) $find_include $find_exclude \) -type f -print0"
+
+ # Find all the font files and store in array
+ files=()
+ while IFS= read -r -d $'\0'; do
+ files+=("$REPLY")
+ done < <(eval "$find_command")
+ #
+ # Remove duplicates (i.e. when both otf and ttf version present)
+ #
+ # Get list of file names without extensions
+ files_dedup=( "${files[@]}" )
+ for i in "${!files_dedup[@]}"; do
+ files_dedup[$i]="${files_dedup[$i]%.*}"
+ done
+
+ # Remove duplicates
+ for i in "${!files_dedup[@]}"; do
+ for j in "${!files_dedup[@]}"; do
+ [ $i = $j ] && continue
+ if [ "${files_dedup[$i]}" = "${files_dedup[$j]}" ]; then
+ ext="${files[$i]##*.}"
+ # Only remove if the extension is the one we don’t want
+ if [ "$ext" != "$extension" ]; then
+ unset files[$i]
+ fi
+ fi
+ done
+ done
+
+ # Copy fonts to the NerdFonts directory
+ mkdir -p "$srcdir/NerdFonts"
+ cp -f "${files[@]}" "$srcdir/NerdFonts"
}
package() {
- install -d ${pkgdir}/usr/share/fonts/OTF
- install -d ${pkgdir}/usr/share/fonts/TTF
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- install -Dm644 ${srcdir}/*.otf ${pkgdir}/usr/share/fonts/OTF
- install -Dm644 ${srcdir}/*.ttf ${pkgdir}/usr/share/fonts/TTF
- install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+ install -Dm644 -t $pkgdir/usr/share/fonts/OTF $srcdir/NerdFonts/*.otf
+ install -Dm644 -t $pkgdir/usr/share/fonts/TTF $srcdir/NerdFonts/*.ttf
+ install -Dm644 -t $pkgdir/usr/share/licenses/$pkgname $srcdir/nerd-fonts-$pkgver/LICENSE
}
diff --git a/nerd-fonts-complete.links b/nerd-fonts-complete.links
deleted file mode 100644
index 9afd4d4b9488..000000000000
--- a/nerd-fonts-complete.links
+++ /dev/null
@@ -1,150 +0,0 @@
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/3270/Medium/complete/3270-Medium Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/3270/Narrow/complete/3270 Narrow Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/AnonymousPro/complete/Anonymice Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/AurulentSansMono/complete/AurulentSansMono-Regular Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/BitstreamVeraSansMono/Bold-Italic/complete/Bitstream Vera Sans Mono Bold Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/BitstreamVeraSansMono/Bold/complete/Bitstream Vera Sans Mono Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/BitstreamVeraSansMono/Italic/complete/Bitstream Vera Sans Mono Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/BitstreamVeraSansMono/Regular/complete/Bitstream Vera Sans Mono Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/CodeNewRoman/complete/Code New Roman Bold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/CodeNewRoman/complete/Code New Roman Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/CodeNewRoman/complete/Code New Roman Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Bold-Italic/complete/DejaVu Sans Mono Bold Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Bold-Italic/complete/DejaVu Sans Mono Bold Oblique for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Bold/complete/DejaVu Sans Mono Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Bold/complete/DejaVu Sans Mono Bold for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Italic/complete/DejaVu Sans Mono Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Italic/complete/DejaVu Sans Mono Oblique for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Regular/complete/DejaVu Sans Mono Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DejaVuSansMono/Regular/complete/DejaVu Sans Mono for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/DroidSansMono/complete/Droid Sans Mono for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FantasqueSansMono/Bold-Italic/complete/Fantasque Sans Mono Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FantasqueSansMono/Bold/complete/Fantasque Sans Mono Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FantasqueSansMono/Italic/complete/Fantasque Sans Mono Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FantasqueSansMono/Regular/complete/Fantasque Sans Mono Regular Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraCode/Bold/complete/Fura Code Bold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraCode/Light/complete/Fura Code Light Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraCode/Medium/complete/Fura Code Medium Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraCode/Regular/complete/Fura Code Regular Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraCode/Retina/complete/Fura Code Retina Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraMono/Bold/complete/Fura Mono Bold for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraMono/Medium/complete/Fura Mono Medium for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/FiraMono/Regular/complete/Fura Mono Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Gohu/complete/GohuFont-Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Gohu/complete/GohuFont-Medium Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hack/Bold/complete/Knack Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hack/BoldItalic/complete/Knack Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hack/Italic/complete/Knack Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hack/Regular/complete/Knack Regular Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Black-Italic/complete/Hasklig Black Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Black-Italic/complete/Hasklug Black Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Black/complete/Hasklig Black Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Black/complete/Hasklug Black Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Bold-Italic/complete/Hasklig Bold Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Bold-Italic/complete/Hasklug Bold Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Bold/complete/Hasklig Bold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Bold/complete/Hasklug Bold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Extra-Light-Italic/complete/Hasklig ExtraLight Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Extra-Light-Italic/complete/Hasklug ExtraLight Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Extra-Light/complete/Hasklig ExtraLight Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Extra-Light/complete/Hasklug ExtraLight Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Italic/complete/Hasklig Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Italic/complete/Hasklug Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Light-Italic/complete/Hasklig Light Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Light-Italic/complete/Hasklug Light Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Light/complete/Hasklig Light Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Light/complete/Hasklug Light Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Medium-Italic/complete/Hasklig Medium Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Medium-Italic/complete/Hasklug Medium Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Medium/complete/Hasklig Medium Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Medium/complete/Hasklug Medium Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Regular/complete/Hasklig Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Regular/complete/Hasklug Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Semibold-Italic/complete/Hasklig Semibold Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Semibold-Italic/complete/Hasklug Semibold Italic Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Semibold/complete/Hasklig Semibold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hasklig/Semibold/complete/Hasklug Semibold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/HeavyData/complete/Heavy Data Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hermit/Bold/complete/Hurmit Bold Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hermit/Light/complete/Hurmit Light Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Hermit/Medium/complete/Hurmit Medium Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Inconsolata/complete/Inconsolata for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Bold-Italic/complete/Iosevka Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Bold-Oblique/complete/Iosevka Bold Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Bold/complete/Iosevka Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Extra-Light-Italic/complete/Iosevka Extralight Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Extra-Light-Oblique/complete/Iosevka Extralight Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Extra-Light/complete/Iosevka Extralight Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Heavy-Italic/complete/Iosevka Heavy Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Heavy-Oblique/complete/Iosevka Heavy Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Heavy/complete/Iosevka Heavy Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Italic/complete/Iosevka Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Light-Italic/complete/Iosevka Light Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Light-Oblique/complete/Iosevka Light Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Light/complete/Iosevka Light Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Medium-Italic/complete/Iosevka Medium Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Medium-Oblique/complete/Iosevka Medium Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Medium/complete/Iosevka Medium Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Oblique/complete/Iosevka Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Regular/complete/Iosevka Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Thin-Italic/complete/Iosevka Thin Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Thin-Oblique/complete/Iosevka Thin Oblique Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Iosevka/Thin/complete/Iosevka Thin Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Lekton/Bold/complete/Lekton-Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Lekton/Italic/complete/Lekton-Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Lekton/Regular/complete/Lekton Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/LiberationMono/complete/Literation Mono Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/MPlus/Bold/complete/M+ 1m bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/MPlus/Light/complete/M+ 1m light Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/MPlus/Medium/complete/M+ 1m medium Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/MPlus/Regular/complete/M+ 1m regular Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/MPlus/Thin/complete/M+ 1m thin Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Meslo/L-DZ/complete/Meslo LG L DZ Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Meslo/L/complete/Meslo LG L Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Meslo/M-DZ/complete/Meslo LG M DZ Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Meslo/M/complete/Meslo LG M Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Meslo/S-DZ/complete/Meslo LG S DZ Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Meslo/S/complete/Meslo LG S Regular for Powerline Nerd Font Complete.otf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monofur/Bold/complete/monofur bold for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monofur/Italic/complete/monofur italic for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monofur/Regular/complete/monofur for Powerline Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monoid/complete/Monoid Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monoid/complete/Monoid Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monoid/complete/Monoid Regular Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Monoid/complete/Monoid Retina Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Mononoki/complete/mononoki Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Mononoki/complete/mononoki Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Mononoki/complete/mononoki Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Mononoki/complete/mononoki-Regular Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/ProFont/profontiix/complete/ProFont IIx Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/ProggyClean/Latin2/complete/ProggyCleanTT CE Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/ProggyClean/Regular/complete/ProggyCleanTT Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/ProggyClean/SlashedZero/complete/ProggyCleanTTSZ Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Light Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Light Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Medium Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Medium Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Thin Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/RobotoMono/complete/Roboto Mono Thin Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/ShareTechMono/complete/Shure Tech Mono Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Black/complete/Sauce Code Pro Black Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Bold/complete/Sauce Code Pro Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Extra-Light/complete/Sauce Code Pro ExtraLight Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Light/complete/Sauce Code Pro Light Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Medium/complete/Sauce Code Pro Medium Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Regular/complete/Sauce Code Pro Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SourceCodePro/Semibold/complete/Sauce Code Pro Semibold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SpaceMono/complete/Space Mono Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SpaceMono/complete/Space Mono Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SpaceMono/complete/Space Mono Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/SpaceMono/complete/Space Mono Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Terminus/terminus-ttf-4.40.1/Bold/complete/Terminess (TTF) Bold Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Terminus/terminus-ttf-4.40.1/BoldItalic/complete/Terminess (TTF) Bold Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Terminus/terminus-ttf-4.40.1/Italic/complete/Terminess (TTF) Italic Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/Terminus/terminus-ttf-4.40.1/Regular/complete/Terminess (TTF) Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/UbuntuMono/Original/complete/Ubuntu Mono Nerd Font Complete.ttf
-https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v1.0.0/patched-fonts/UbuntuMono/Regular/complete/Ubuntu Mono derivative Powerline Nerd Font Complete.ttf