summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571b77c22962..270ea42f042b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
pkgbase = nerd-fonts-tinos
pkgdesc = Patched font Tinos from Nerd Fonts Library
- pkgver = 2.1.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/ryanoasis/nerd-fonts
arch = any
- groups = nerd-fonts
- license = MIT
- depends = fontconfig
- provides = nerd-fonts-tinos
+ license = Apache
+ provides = ttf-nerd-fonts-tinos
conflicts = nerd-fonts-git
conflicts = nerd-fonts-complete
- source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/Tinos.zip
- source = https://github.com/ryanoasis/nerd-fonts/raw/v2.1.0/LICENSE
- sha1sums = SKIP
- sha1sums = SKIP
+ source = nerd-fonts-tinos-2.3.0.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v2.3.0/Tinos.zip
+ sha256sums = 8cb947caff0eb80bda25b01aa235259c0f7dc8dba1f0bde695ca6c1e1e123186
pkgname = nerd-fonts-tinos
-
diff --git a/PKGBUILD b/PKGBUILD
index 5af301f2e893..d7b17f9c8bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,18 @@
-# Packager: pryme-svg <edoc.www@gmail.com>
-# Maintainer: pryme-svg <edoc.www@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: pryme-svg <edoc.www@gmail.com>
pkgname=nerd-fonts-tinos
-pkgver=2.1.0
+pkgver=2.3.0
pkgrel=1
pkgdesc="Patched font Tinos from Nerd Fonts Library"
arch=("any")
url="https://github.com/ryanoasis/nerd-fonts"
-license=('MIT')
-depends=('fontconfig')
-provides=("${pkgname}")
+license=('Apache')
+provides=('ttf-nerd-fonts-tinos')
conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
-groups=("nerd-fonts")
-source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Tinos.zip"
- "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
-sha1sums=(SKIP
- SKIP)
+source=("$pkgname-$pkgver.zip::$url/releases/download/v$pkgver/Tinos.zip")
+sha256sums=('8cb947caff0eb80bda25b01aa235259c0f7dc8dba1f0bde695ca6c1e1e123186')
package() {
- find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
- find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
}
-