summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..571b77c22962
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-tinos
+ pkgdesc = Patched font Tinos from Nerd Fonts Library
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-tinos
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/Tinos.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.1.0/LICENSE
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = nerd-fonts-tinos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83a13eefa249
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Packager: William Chen <edoc.www@gmail.com>
+# Maintainer: William Chen <edoc.www@gmail.com>
+
+pkgname=nerd-fonts-tinos
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Patched font Tinos from Nerd Fonts Library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=("${pkgname}")
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Tinos.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=(SKIP
+ SKIP)
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+