summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27cc8efa03fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ness-stretch-git
+ pkgdesc = Implements a phase randomized Real FFT time stretch algorithm, the NessStretch, which splits the original sound file into 9 discrete frequency bands, and uses a decreasing frame size to correspond to increasing frequency.
+ pkgver = r178.e64eb33
+ pkgrel = 1
+ url = https://github.com/spluta/TimeStretch
+ arch = x86_64
+ groups = pro-audio
+ license = GPL
+ makedepends = cargo
+ makedepends = rust
+ source = ness-stretch-git::git+https://github.com/spluta/TimeStretch
+ sha256sums = SKIP
+
+pkgname = ness-stretch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..940acef07c95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mads Kjeldgaard <mail@madskjeldgaard.dk>
+pkgname=ness-stretch-git
+pkgver=r178.e64eb33
+pkgrel=1
+pkgdesc="Implements a phase randomized Real FFT time stretch algorithm, the NessStretch, which splits the original sound file into 9 discrete frequency bands, and uses a decreasing frame size to correspond to increasing frequency."
+arch=('x86_64')
+url="https://github.com/spluta/TimeStretch"
+license=('GPL')
+groups=('pro-audio')
+depends=('gcc-libs')
+makedepends=('cargo' 'rust')
+source=("$pkgname::git+${url}")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+check() {
+ cd "$pkgname/rust"
+ cargo test --locked
+}
+
+build() {
+ cd "$pkgname/rust"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname/rust"
+ install -Dm755 "target/release/ness_stretch" "$pkgdir/usr/bin/ness_stretch"
+}