summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xgetnessus.sh12
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd44c843726d..30be2728f171 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Jul 19 16:59:19 UTC 2016
+# Tue Jul 19 17:57:44 UTC 2016
pkgbase = nessus
pkgdesc = Vulnerability scanner
pkgver = 6.8.0
diff --git a/PKGBUILD b/PKGBUILD
index aae4041c0284..54b4b3670b9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ source=($_bigver.x86_64.rpm
nessus.sh
LICENSE.NESSUS
nessus.install)
-md5sums=('d41d8cd98f00b204e9800998ecf8427e'
+md5sums=('4106308f11c6b56f05932ee7bf9e71e1'
'8c5772ac63f97d94475fe03e80d6ba5c'
'8ff98bc9488304fcb66753d3cfb5f30e'
'd9d25d4075acc50c0050c7a4f244c7cb')
diff --git a/getnessus.sh b/getnessus.sh
index a7d6795eba29..7b3e62ab0f86 100755
--- a/getnessus.sh
+++ b/getnessus.sh
@@ -19,6 +19,15 @@ WGET_HSTS="--no-hsts"
RELEASE=6.8.0
+echo -e "The Nessus downloader is temporarily broken due to an upstream change."
+echo -e "Please download Nessus from http://www.tenable.com/products/nessus/select-your-operating-system#tos"
+echo -e "Then put Nessus-$RELEASE-fc20.x86_64.rpm in the tmp folder for this package and run the installer again."
+exit
+
+
+
+
+
echo -e "Downloading Nessus $RELEASE from downloads.nessus.org ... "
if [ -f Nessus-$RELEASE-fc20.x86_64.rpm ] ; then
@@ -30,8 +39,9 @@ fi
#ID=$(wget $WGET_HSTS -qO - /dev/null "https://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes" | grep "og:description" | cut -d= -f3 | sed -e 's/^"*//' | cut -d* -f1)
#DOWNLOAD=$(wget $WGET_HSTS -O/dev/null -q "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=$ID" && echo "exists" || echo "not exist")
DOWNLOAD=$(wget $WGET_HSTS -O/dev/null -q "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=39834650794bd3c9ec30dbb14d625b23" && echo "exists" || echo "not exist")
+http://downloads.nessus.org/nessus3dl.php?file=Nessus-6.8.0-fc20.x86_64.rpm&licence_accept=yes&t=39834650794bd3c9ec30dbb14d625b23
-echo "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=$ID"
+echo "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=39834650794bd3c9ec30dbb14d625b23"
if [[ $DOWNLOAD == exists ]] ;then
wget $WGET_HSTS -q "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=$ID" -O Nessus-$RELEASE-fc20.x86_64.rpm
else