summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3c4f6f50ecc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = netcalc
+ pkgdesc = IP network calculator - Simplified clone of sipcalc with ipcalc looks.
+ pkgver = 2.1.6
+ pkgrel = 1
+ url = https://github.com/troglobit/netcalc
+ arch = any
+ license = GPL3
+ source = https://github.com/troglobit/netcalc/archive/v2.1.6.tar.gz
+ sha1sums = 75628133999dae0604369c0874020469a184d3ae
+
+pkgname = netcalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d531cb31b2f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: hcra <hcra at u53r dot space>
+
+pkgname=netcalc
+pkgver=2.1.6
+pkgrel=1
+pkgdesc="IP network calculator - Simplified clone of sipcalc with ipcalc looks."
+arch=('any')
+url="https://github.com/troglobit/netcalc"
+license=('GPL3')
+source=(https://github.com/troglobit/$pkgname/archive/v$pkgver.tar.gz)
+sha1sums=('75628133999dae0604369c0874020469a184d3ae')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./autogen.sh
+
+ ./configure --prefix=/usr
+ make -j5
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install-strip
+}