summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD21
-rw-r--r--eduroam-uu16
-rw-r--r--install5
5 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cea9e379e0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = netctl-eduroam-uu
+ pkgdesc = Example netctl profile for eduroam at the University of Utrecht
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.uu.nl/university/utrecht/NL/praktischezaken/ICT/Paginas/Eduroam.aspx
+ install = install
+ arch = any
+ license = MIT
+ depends = ca-certificates
+ depends = netctl
+ depends = ppp
+ source = eduroam-uu
+ md5sums = 0008f47b858ad98a511b10694a1a534e
+
+pkgname = netctl-eduroam-uu
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..20efd1b3e976
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2015
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f7d9c514233
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintained by: Zeger-Jan van de Weg
+# Contributed: github.com/orschiro
+
+pkgname=netctl-eduroam-uu
+pkgver=1.1
+pkgrel=1
+pkgdesc='Example netctl profile for eduroam at the University of Utrecht'
+arch=(any)
+url=http://www.uu.nl/university/utrecht/NL/praktischezaken/ICT/Paginas/Eduroam.aspx
+license=(MIT)
+depends=(ca-certificates netctl ppp)
+source=(eduroam-uu)
+install=install
+md5sums=('0008f47b858ad98a511b10694a1a534e')
+
+package() {
+ mkdir -p $pkgdir/etc/netctl/examples/
+ cp eduroam-uu $pkgdir/etc/netctl/examples/
+}
+
+
diff --git a/eduroam-uu b/eduroam-uu
new file mode 100644
index 000000000000..628e40f2fda4
--- /dev/null
+++ b/eduroam-uu
@@ -0,0 +1,16 @@
+Connection='wireless'
+Interface=<your interface> # ex: wls1
+Security='wpa-configsection'
+Description="eduroam network Utrecht University"
+IP='dhcp'
+TimeoutWPA=60
+WPAConfigSection=(
+ 'ssid="eduroam"'
+ 'key_mgmt=WPA-EAP'
+ 'eap=PEAP'
+ 'proto=WPA2'
+ 'phase2="auth=None"'
+ 'identity="<solis ID>@soliscom.uu.nl"' # ex: 4127918
+ 'ca_cert="/usr/share/ca-certificates/trust-source/mozilla.trust.crt"'
+ 'password="<solis ID passphrase>"'
+)
diff --git a/install b/install
new file mode 100644
index 000000000000..54f74f23a216
--- /dev/null
+++ b/install
@@ -0,0 +1,5 @@
+post_upgrade() {
+ echo "To use eduroam: copy the template..."
+ echo " cp /etc/netctl/examples/eduroam-uu /etc/netctl/eduroam-uu"
+ echo "... and edit it, to match your credentials"
+}