aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xnetease-cloud-music.bash1
-rw-r--r--patch.c1
4 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b16ff23bfecf..287a7f8556ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netease-cloud-music
pkgdesc = Netease Cloud Music, converted from .deb package
pkgver = 1.2.1
- pkgrel = 6
+ pkgrel = 7
url = https://music.163.com/
arch = x86_64
license = custom
@@ -15,8 +15,8 @@ pkgbase = netease-cloud-music
source = netease-cloud-music.bash
sha256sums = 1ee9f02842e6c2c8c79c48b2e932074f9c213a8eb4238e5e63f20438562fecbb
sha256sums = SKIP
- sha256sums = a92650cfd889b1d5c3192adc0785627721f1c60dbfe08a35f124f6f5cc9613dc
+ sha256sums = 1080edde7cbd3716464598f80dd5c715737775bec9501740295a40c48236b109
sha256sums = 0c470e76741c549e5530b2e57d57281eaf198fd56ca3590f664154365b744cf9
- sha256sums = b11bd6ab4abcc375850668f54a4912948875ad9f9b93cfc24f89de16ec1e8ea7
+ sha256sums = 3b2c2e2251461d4ee0509ac00d1677d9fff3eaca24f90ef8678efba2c30ae95f
pkgname = netease-cloud-music
diff --git a/PKGBUILD b/PKGBUILD
index 9e5ac898f056..7dc77a830b63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=netease-cloud-music
pkgver=1.2.1
_pkgdate=20190428
-pkgrel=6
+pkgrel=7
pkgdesc="Netease Cloud Music, converted from .deb package"
arch=("x86_64")
url="https://music.163.com/"
@@ -19,9 +19,9 @@ source=(
)
sha256sums=('1ee9f02842e6c2c8c79c48b2e932074f9c213a8eb4238e5e63f20438562fecbb'
'SKIP'
- 'a92650cfd889b1d5c3192adc0785627721f1c60dbfe08a35f124f6f5cc9613dc'
+ '1080edde7cbd3716464598f80dd5c715737775bec9501740295a40c48236b109'
'0c470e76741c549e5530b2e57d57281eaf198fd56ca3590f664154365b744cf9'
- 'b11bd6ab4abcc375850668f54a4912948875ad9f9b93cfc24f89de16ec1e8ea7')
+ '3b2c2e2251461d4ee0509ac00d1677d9fff3eaca24f90ef8678efba2c30ae95f')
DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
diff --git a/netease-cloud-music.bash b/netease-cloud-music.bash
index e3240b10fbd2..5628baa3bbb1 100755
--- a/netease-cloud-music.bash
+++ b/netease-cloud-music.bash
@@ -3,6 +3,7 @@ HERE="$(dirname "$(readlink -f "${0}")")"
export LD_LIBRARY_PATH="${HERE}"/libs
export QT_PLUGIN_PATH="${HERE}"/plugins
export QT_QPA_PLATFORM_PLUGIN_PATH="${HERE}"/plugins/platforms
+export QT_QPA_PLATFORM=xcb
export LD_PRELOAD="${HERE}"/libnetease-patch.so
exec "${HERE}"/netease-cloud-music $@
diff --git a/patch.c b/patch.c
index e1df0626237a..f34e989190cd 100644
--- a/patch.c
+++ b/patch.c
@@ -116,6 +116,7 @@ int execve(const char *path, char *const argv[], char *const envp[])
STRING_WITH_LEN_INIT("LD_PRELOAD="),
STRING_WITH_LEN_INIT("QT_PLUGIN_PATH="),
STRING_WITH_LEN_INIT("QT_QPA_PLATFORM_PLUGIN_PATH="),
+ STRING_WITH_LEN_INIT("QT_QPA_PLATFORM="),
};
size_t nenv;