summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4a7be791e57..69d72435d3f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,7 @@ pkgbase = netease-musicbox-git
makedepends = python2-future
makedepends = python2-lxml
makedepends = python2-cryptography
+ makedepends = python2-requests-cache
makedepends = python
makedepends = mpg123
makedepends = python-beautifulsoup4
@@ -25,6 +26,7 @@ pkgbase = netease-musicbox-git
makedepends = python-future
makedepends = python-lxml
makedepends = python-cryptography
+ makedepends = python-requests-cache
depends = mpg123
optdepends = aria2: music caching
optdepends = libnotify: notifications
@@ -44,6 +46,7 @@ pkgname = netease-musicbox-git
depends = python-future
depends = python-lxml
depends = python-cryptography
+ depends = python-requests-cache
optdepends = aria2: music caching
optdepends = libnotify: notifications
optdepends = python-pyqt4: lyrics support
@@ -59,6 +62,7 @@ pkgname = netease-musicbox-py2-git
depends = python2-future
depends = python2-lxml
depends = python2-cryptography
+ depends = python2-requests-cache
optdepends = aria2: music caching
optdepends = python2-keybinder2: global keybindings
optdepends = libnotify: notifications
diff --git a/PKGBUILD b/PKGBUILD
index 7574d80c7c57..bf57f0cb58af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,14 @@ optdepends=('aria2: music caching'
'libnotify: notifications'
)
license=('MIT')
-_py2depends=('python2' 'mpg123' 'python2-beautifulsoup4'
- 'python2-requests' 'python2-setuptools'
- 'python2-crypto' 'python2-future' 'python2-lxml'
- 'python2-cryptography' )
-_py3depends=('python' 'mpg123' 'python-beautifulsoup4'
- 'python-requests' 'python-setuptools'
- 'python-crypto' 'python-future' 'python-lxml'
- 'python-cryptography')
+_py2depends=('python2' 'mpg123' 'python2-beautifulsoup4'
+ 'python2-requests' 'python2-setuptools'
+ 'python2-crypto' 'python2-future' 'python2-lxml'
+ 'python2-cryptography' 'python2-requests-cache')
+_py3depends=('python' 'mpg123' 'python-beautifulsoup4'
+ 'python-requests' 'python-setuptools'
+ 'python-crypto' 'python-future' 'python-lxml'
+ 'python-cryptography' 'python-requests-cache')
makedepends=('git'
${_py2depends[@]}
${_py3depends[@]}