summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--xt_FULLCONENAT.c.patch11
3 files changed, 6 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e825abe3faf..6bf86b17779b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netfilter-full-cone-nat-dkms
pkgdesc = A kernel module that turns MASQUERADE into full cone SNAT
- pkgver = git+ec14efe
- pkgrel = 3
+ pkgver = git+bc3fb32
+ pkgrel = 4
url = https://github.com/Chion82/netfilter-full-cone-nat
arch = x86_64
license = GPL2
@@ -9,11 +9,9 @@ pkgbase = netfilter-full-cone-nat-dkms
conflicts = netfilter-full-cone-nat
source = dkms.conf
source = Makefile.patch
- source = xt_FULLCONENAT.c.patch
source = git+https://github.com/Chion82/netfilter-full-cone-nat
md5sums = 426b17a1544478bcbe5ecc56fd392db0
md5sums = ca672d85174ea52d57758bd53c0a0ed9
- md5sums = ceda7d1fc776845741cc0acf12f3fb2e
md5sums = SKIP
pkgname = netfilter-full-cone-nat-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 72bc0b5b5974..8d536b9dd3a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgbase=netfilter-full-cone-nat
pkgname=netfilter-full-cone-nat-dkms
-pkgver=git+ec14efe
-pkgrel=3
+pkgver=git+bc3fb32
+pkgrel=4
pkgdesc="A kernel module that turns MASQUERADE into full cone SNAT"
arch=('x86_64')
url="https://github.com/Chion82/netfilter-full-cone-nat"
@@ -11,17 +11,14 @@ license=('GPL2')
depends=('dkms')
conflicts=("${_pkgbase}")
source=('dkms.conf'
- 'Makefile.patch'
- 'xt_FULLCONENAT.c.patch'
- 'git+https://github.com/Chion82/netfilter-full-cone-nat')
+ 'Makefile.patch'
+ 'git+https://github.com/Chion82/netfilter-full-cone-nat')
md5sums=('426b17a1544478bcbe5ecc56fd392db0'
'ca672d85174ea52d57758bd53c0a0ed9'
- 'ceda7d1fc776845741cc0acf12f3fb2e'
'SKIP')
build() {
cd ${srcdir}/${_pkgbase}
- patch -p1 -i "${srcdir}"/xt_FULLCONENAT.c.patch
patch -p1 -i "${srcdir}"/Makefile.patch
}
diff --git a/xt_FULLCONENAT.c.patch b/xt_FULLCONENAT.c.patch
deleted file mode 100644
index 1359b46c41e7..000000000000
--- a/xt_FULLCONENAT.c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/xt_FULLCONENAT.c
-+++ b/xt_FULLCONENAT.c
-@@ -472,7 +472,7 @@ static unsigned int fullconenat_tg(struct sk_buff *skb, const struct xt_action_p
-
- struct nat_mapping *mapping, *src_mapping;
- unsigned int ret;
-- struct nf_nat_range newrange;
-+ struct nf_nat_range2 newrange;
-
- __be32 new_ip, ip;
- uint16_t port, original_port, want_port;