summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a5e82375ad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jan 30 17:58:43 UTC 2017
+pkgbase = netinfo-ffi
+ pkgdesc = C wrapper for netinfo, which groups network usage by process
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/ChangSpivey/netinfo-ffi
+ arch = i686
+ arch = x86_64
+ license = AGPL-3.0
+ makedepends = cargo
+ depends = gcc-libs
+ source = https://github.com/ChangSpivey/netinfo-ffi/archive/v0.3.0.tar.gz
+ sha512sums = 9f553eed7d1a113bb0c68e34ed5b0028c8b74648d1c8109895a63b58c47aaa49dd2fe8bfee8416dc7dfef9872ac3ba6d9abcd9cac6a900284dd5b3f49b7c1750
+
+pkgname = netinfo-ffi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db7dc4818d67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=netinfo-ffi
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="C wrapper for netinfo, which groups network usage by process"
+arch=('i686' 'x86_64')
+url="https://github.com/ChangSpivey/netinfo-ffi"
+license=('AGPL-3.0')
+depends=('gcc-libs')
+makedepends=('cargo')
+source=("https://github.com/ChangSpivey/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('9f553eed7d1a113bb0c68e34ed5b0028c8b74648d1c8109895a63b58c47aaa49dd2fe8bfee8416dc7dfef9872ac3ba6d9abcd9cac6a900284dd5b3f49b7c1750')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm644 "target/release/libnetinfo.so" "$pkgdir/usr/lib/libnetinfo.so"
+ install -Dm644 "src/netinfo.h" "$pkgdir/usr/include/netinfo.h"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}