summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 377277d12b55..71741d20a3ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neverball
pkgdesc = 3D game similar to Super Monkey Ball or Marble Madness
pkgver = 1.6.0
- pkgrel = 4
+ pkgrel = 5
url = http://neverball.org/
arch = x86_64
license = GPL
@@ -16,8 +16,10 @@ pkgbase = neverball
depends = xdg-utils
source = http://neverball.org/neverball-1.6.0.tar.gz
source = neverball-filesystem.patch::https://github.com/Neverball/neverball/commit/27279856.patch
+ source = neverball-gcc10.patch::https://github.com/Neverball/neverball/commit/a42492b8db06934c7a794630db92e3ff6ebaadaa.patch
sha256sums = 73fe63cca4f96e2d355480d03bc0b2904e83a0abdf65fe8c52db5cc3cca88fa0
sha256sums = b93f17315766a8f1a70f46716cd99260981f4797ec1589b26f03bfca201a8e0d
+ sha256sums = 6bc37c97b9fbbdbcb890344d08a958b038b0333bc74230147b93d9be9341d89e
pkgname = neverball
diff --git a/PKGBUILD b/PKGBUILD
index 302f6dfebdd9..cef5a7773f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
+# Maintainer: SanskritFritz (gmail)
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Eric BĂ©langer <eric@archlinux.org>
+# Contributor: useraur111 (AUR)
pkgname=neverball
pkgver=1.6.0
-pkgrel=4
+pkgrel=5
pkgdesc="3D game similar to Super Monkey Ball or Marble Madness"
arch=('x86_64')
url="http://neverball.org/"
@@ -12,13 +14,16 @@ depends=('sdl2_ttf' 'libgl' 'libpng' 'libjpeg' 'libvorbis' 'physfs' \
'hicolor-icon-theme' 'xdg-utils')
makedepends=('mesa')
source=(http://neverball.org/${pkgname}-${pkgver}.tar.gz
- neverball-filesystem.patch::"https://github.com/Neverball/neverball/commit/27279856.patch")
+ neverball-filesystem.patch::"https://github.com/Neverball/neverball/commit/27279856.patch"
+ neverball-gcc10.patch::"https://github.com/Neverball/neverball/commit/a42492b8db06934c7a794630db92e3ff6ebaadaa.patch")
sha256sums=('73fe63cca4f96e2d355480d03bc0b2904e83a0abdf65fe8c52db5cc3cca88fa0'
- 'b93f17315766a8f1a70f46716cd99260981f4797ec1589b26f03bfca201a8e0d')
+ 'b93f17315766a8f1a70f46716cd99260981f4797ec1589b26f03bfca201a8e0d'
+ '6bc37c97b9fbbdbcb890344d08a958b038b0333bc74230147b93d9be9341d89e')
prepare() {
cd $pkgname-$pkgver
patch -Np1 <../neverball-filesystem.patch # Fix creating settings dir
+ patch -Np1 <../neverball-gcc10.patch # Fix building with -fno-common
}
build() {