summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rwxr-xr-xset-nc-perms.sh4
4 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf3bcbc7462f..1eaa263d3c3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Sat Jun 4 16:11:36 UTC 2016
+# Tue Jun 14 18:47:55 UTC 2016
pkgbase = nextcloud
pkgdesc = nextcloud: A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way
- pkgver = 9.0.2
+ pkgver = 9.0.50
pkgrel = 1
url = https://nextcloud.com
install = nextcloud.install
arch = any
- license = GPL
+ license = AGPL
depends = php
depends = php-gd
optdepends = php-apache: to use the Apache web server
@@ -25,9 +25,11 @@ pkgbase = nextcloud
options = !strip
options = emptydirs
source = apache.example.conf
+ source = https://download.nextcloud.com/server/releases/nextcloud-9.0.50.tar.bz2
source = set-nc-perms.sh
md5sums = bc2b02b0562b7a58e660e33acd4202bc
- md5sums = 106536581b9d2a69b363f375c2dbd349
+ md5sums = 83cdce392a8520869933ccf75addb836
+ md5sums = 0c996a76cf39b2bccde8d74ac062895e
pkgname = nextcloud
diff --git a/.gitignore b/.gitignore
index dae0ea37f7bc..41c065c69192 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@
*.asc
*.pkg.tar.xz
*.patch
+*.pkg.tar
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 554d3965bb91..c7272858ed84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=nextcloud
-pkgver=9.0.2
+pkgver=9.0.50
pkgrel=1
pkgdesc="nextcloud: A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way"
url="https://nextcloud.com"
arch=('any')
-license=('GPL')
+license=('AGPL')
depends=('php' 'php-gd')
optdepends=('php-apache: to use the Apache web server'
'php-sqlite: to use the SQLite database backend'
@@ -22,13 +22,14 @@ optdepends=('php-apache: to use the Apache web server'
'libreoffice: file preview')
options=('!strip')
install=${pkgname}.install
-#validpgpkeys=('E3036906AD9F30807351FAC32D5D5E97F6978A26')
-#source=("https://download.owncloud.org/community/owncloud-${pkgver}.tar.bz2"{,.asc}
+#validpgpkeys=('2880 6A87 8AE4 23A2 8372 792E D758 99B9 A724 937A')
source=("apache.example.conf"
-# "https://github.com/nextcloud/server/archive/v${pkgver}.tar.gz"
+ "https://download.nextcloud.com/server/releases/nextcloud-${pkgver}.tar.bz2"
+# "https://download.nextcloud.com/server/releases/nextcloud-${pkgver}.tar.bz2"{,.asc}
"set-nc-perms.sh")
md5sums=('bc2b02b0562b7a58e660e33acd4202bc'
- '106536581b9d2a69b363f375c2dbd349')
+ '83cdce392a8520869933ccf75addb836'
+ '0c996a76cf39b2bccde8d74ac062895e')
options=(!strip emptydirs)
@@ -38,14 +39,14 @@ options=(!strip emptydirs)
package() {
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- cp "${srcdir}/nextcloud/COPYING-*" "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp "${srcdir}/nextcloud/COPYING-AGPL" "${pkgdir}/usr/share/licenses/${pkgname}"
mkdir -p "${pkgdir}/usr/share/webapps"
cp -a nextcloud "${pkgdir}/usr/share/webapps/."
install -D -m755 "${srcdir}/set-nc-perms.sh" "${pkgdir}/usr/bin/set-nc-perms"
install -m644 -D "${srcdir}/apache.example.conf" -t "${pkgdir}/etc/webapps/nextcloud"
- ln -s /usr/share/webapps/nextcloud/ncc "${pkgdir}/usr/bin/ncc"
+ ln -s /usr/share/webapps/nextcloud/occ "${pkgdir}/usr/bin/occ"
}
# vim:set ts=2 sw=2 et:
diff --git a/set-nc-perms.sh b/set-nc-perms.sh
index b2b10efe318a..19ddef43466f 100755
--- a/set-nc-perms.sh
+++ b/set-nc-perms.sh
@@ -1,5 +1,5 @@
#!/usr/bin/env bash
-# from https://doc.owncloud.org/server/9.0/admin_manual/installation/installation_wizard.html#strong-perms-label
+# from https://docs.nextcloud.org/server/9/admin_manual/installation/installation_wizard.html#strong-perms-label
# run with the argument "runtime" to set the proper runtime permissions
# run with the argument "upgrade" to set the proper upgrade permissions
@@ -27,7 +27,7 @@ runtime() {
chown -R ${htuser}:${htgroup} ${ncpath}/themes/
chown -R ${htuser}:${htgroup} ${ncpath}/updater/
- chmod +x ${ncpath}/ncc
+ chmod +x ${ncpath}/occ
printf "chmod/chown .htaccess\n"
if [ -f ${ncpath}/.htaccess ]