summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD2
-rw-r--r--nextcloud-systemd-timers.install15
4 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 131e1b037b06..046808251c41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = nextcloud-systemd-timers
install = nextcloud-systemd-timers.install
arch = any
license = GPL
- conflicts = nextcloud-systemd-cron
source = nextcloud-cron.service
source = nextcloud-cron.timer
source = nextcloud-preview-pre-generate.service
diff --git a/.gitignore b/.gitignore
index 3491100687a6..8e5af080034f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,4 @@
/update
+/pkg/
+/src/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index e5ba83b9af25..bf61b9022257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ makedepends=()
checkdepends=()
optdepends=()
provides=()
-conflicts=(nextcloud-systemd-cron)
+conflicts=()
replaces=()
backup=()
options=()
diff --git a/nextcloud-systemd-timers.install b/nextcloud-systemd-timers.install
index 9c4d44ad0ee2..cdf3a5b9f904 100644
--- a/nextcloud-systemd-timers.install
+++ b/nextcloud-systemd-timers.install
@@ -34,11 +34,16 @@ post_install() {
echo '$ systemctl list-timers'
}
-## arg 1: the new package version
-## arg 2: the old package version
-#pre_upgrade() {
- # do something here
-#}
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ if [[ $1 == 0.6 ]]
+ then
+ echo "The systemd unit directory has changed from"
+ echo "/etc/systemd/system to /usr/lib/systemd/system."
+ echo "Please deactivate the old units, and activate the new ones after the upgrade."
+ fi
+}
## arg 1: the new package version
## arg 2: the old package version