summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--PKGBUILD.in13
3 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8cec4404d4b..b5c3a2d9cd25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = nextpnr-generic-nightly
pkgdesc = nextpnr portable FPGA place and route tool - generic
- pkgver = f5cc959c_20211124
+ pkgver = 20240424_nextpnr_0.7_28_gedcafcf0
pkgrel = 1
epoch = 1
url = https://github.com/YosysHQ/nextpnr
- arch = any
+ arch = x86_64
license = custom:ISC
makedepends = git
makedepends = gcc
@@ -19,8 +19,9 @@ pkgbase = nextpnr-generic-nightly
depends = boost-libs
depends = qt5-base
conflicts = nextpnr-git
+ conflicts = nextpnr-all-nightly
options = !strip
- source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=f5cc959c
+ source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=edcafcf0
sha256sums = SKIP
pkgname = nextpnr-generic-nightly
diff --git a/PKGBUILD b/PKGBUILD
index 1bf69023615d..6055c2c8b998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Aki-nyan <aur@catgirl.link>
pkgname=nextpnr-generic-nightly
-pkgver=f5cc959c_20211124
+pkgver=20240424_nextpnr_0.7_28_gedcafcf0
pkgrel=1
epoch=1
pkgdesc="nextpnr portable FPGA place and route tool - generic"
-arch=("any")
+arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
groups=()
@@ -20,10 +20,11 @@ optdepends=()
makedepends=("git" "gcc" "cmake" "ninja" "pkgconf" "gawk" "eigen" "boost")
conflicts=(
"nextpnr-git"
+ "nextpnr-all-nightly"
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=f5cc959c
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=edcafcf0"
)
sha256sums=(
"SKIP"
@@ -33,7 +34,6 @@ _PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
[ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
- cd ..
}
build() {
@@ -47,14 +47,11 @@ build() {
-DCMAKE_INSTALL_PREFIX=${_PREFIX} \
-DUSE_OPENMP=ON \
..
- cd ..
- ninja -C build-generic
- cd ..
+ ninja
}
package() {
cd "${srcdir}/nextpnr"
DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
- cd ..
}
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 06ae3785796f..d6943d5020ce 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -1,11 +1,11 @@
# Maintainer: Aki-nyan <aur@catgirl.link>
pkgname=nextpnr-generic-nightly
-pkgver=@NPR_VER@
+pkgver=@EDA_VER@
pkgrel=1
epoch=1
pkgdesc="nextpnr portable FPGA place and route tool - generic"
-arch=("any")
+arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
groups=()
@@ -20,10 +20,11 @@ optdepends=()
makedepends=("git" "gcc" "cmake" "ninja" "pkgconf" "gawk" "eigen" "boost")
conflicts=(
"nextpnr-git"
+ "nextpnr-all-nightly"
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=@NPR_HASH@
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=@EDA_HASH@"
)
sha256sums=(
"SKIP"
@@ -33,7 +34,6 @@ _PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
[ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
- cd ..
}
build() {
@@ -47,14 +47,11 @@ build() {
-DCMAKE_INSTALL_PREFIX=${_PREFIX} \
-DUSE_OPENMP=ON \
..
- cd ..
- ninja -C build-generic
- cd ..
+ ninja
}
package() {
cd "${srcdir}/nextpnr"
DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
- cd ..
}