summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.in15
3 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38e9141484fb..5ee03b9df80e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = nextpnr-generic-nightly
pkgdesc = nextpnr portable FPGA place and route tool - generic
- pkgver = fd2d4a8f_20211125
+ pkgver = 20220219_347ba3a
pkgrel = 1
epoch = 1
url = https://github.com/YosysHQ/nextpnr
- arch = any
+ arch = x86_64
license = custom:ISC
makedepends = git
makedepends = gcc
@@ -20,7 +20,7 @@ pkgbase = nextpnr-generic-nightly
depends = qt5-base
conflicts = nextpnr-git
options = !strip
- source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=fd2d4a8f
+ source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=347ba3a
sha256sums = SKIP
pkgname = nextpnr-generic-nightly
diff --git a/PKGBUILD b/PKGBUILD
index 84c94bb2adee..fa48f2200fe2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Aki-nyan <aur@catgirl.link>
pkgname=nextpnr-generic-nightly
-pkgver=fd2d4a8f_20211125
+pkgver=20220219_347ba3a
pkgrel=1
epoch=1
pkgdesc="nextpnr portable FPGA place and route tool - generic"
-arch=("any")
+arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
groups=()
@@ -23,7 +23,7 @@ conflicts=(
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=fd2d4a8f
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=347ba3a"
)
sha256sums=(
"SKIP"
@@ -33,7 +33,6 @@ _PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
[ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
- cd ..
}
build() {
@@ -47,14 +46,16 @@ build() {
-DCMAKE_INSTALL_PREFIX=${_PREFIX} \
-DUSE_OPENMP=ON \
..
- cd ..
- ninja -C build-generic
- cd ..
+ ninja
+}
+
+check() {
+ cd "${srcdir}/nextpnr"
+ ninja -C build-generic test
}
package() {
cd "${srcdir}/nextpnr"
DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
- cd ..
}
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 06ae3785796f..41fbcab42713 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -5,7 +5,7 @@ pkgver=@NPR_VER@
pkgrel=1
epoch=1
pkgdesc="nextpnr portable FPGA place and route tool - generic"
-arch=("any")
+arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
groups=()
@@ -23,7 +23,7 @@ conflicts=(
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=@NPR_HASH@
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=@NPR_HASH@"
)
sha256sums=(
"SKIP"
@@ -33,7 +33,6 @@ _PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
[ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
- cd ..
}
build() {
@@ -47,14 +46,16 @@ build() {
-DCMAKE_INSTALL_PREFIX=${_PREFIX} \
-DUSE_OPENMP=ON \
..
- cd ..
- ninja -C build-generic
- cd ..
+ ninja
+}
+
+check() {
+ cd "${srcdir}/nextpnr"
+ ninja -C build-generic test
}
package() {
cd "${srcdir}/nextpnr"
DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
- cd ..
}