summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD14
-rw-r--r--nexus-oss.install25
-rw-r--r--nexus-oss.properties3
5 files changed, 44 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b816994552ed..32b368ab2c2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = nexus-oss
pkgdesc = Nexus 3 Repository OSS
pkgver = 3.7.0.04
- pkgrel = 1
+ pkgrel = 2
url = http://nexus.sonatype.org
install = nexus-oss.install
arch = any
depends = jre8-openjdk-headless
provides = nexus-oss
+ backup = var/lib/nexus-oss/etc/nexus.properties
source = http://download.sonatype.com/nexus/3/nexus-3.7.0-04-unix.tar.gz
source = nexus-oss
source = nexus-oss.install
+ source = nexus-oss.properties
source = nexus-oss.service
source = nexus-oss.sysusers
source = nexus-oss.tmpfiles
@@ -17,7 +19,8 @@ pkgbase = nexus-oss
source = pref_jre.cfg
sha256sums = 542912830cb804bc2cad1dc247d28440ecd14edd36684bf8bd55d6999b5e083f
sha256sums = 3d2ebc2a796dbdc7e7e3b97e4c3272292169c898776e111f503f0517e434caff
- sha256sums = 1b5628130205db11429fc26527e38d3cd613f6c00d08cc19d49a6fe9c1a43d06
+ sha256sums = 182dc7f3c809e1de9a1b205c933302f353ed618ea554fb70bac53f0d368eae0c
+ sha256sums = dcdef5614db12f38b3da0b9de1b52fb7fa402af6621a825981c6168a34a6ad9b
sha256sums = 0fa963f12b4f2d7da4b25cf7027ced34dc73a361e4c8ddc9b939c00faaeb531e
sha256sums = 77d699b5ccf6387fa2f69df2cd71cdb75b4ffbf46a10110dd6c0e2802783dbef
sha256sums = 32bfa3f82038f89d2f7140eada1faadf416ae835d5e5cb0573c528398249a63e
diff --git a/.gitignore b/.gitignore
index 6f72e81ab811..f79c1a2d05a0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
+.*
+!.SRCINFO
+!.gitignore
pkg
src
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index fbef8d149b99..6a2b1fd6c539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,17 @@ _patch=04
pkgname=nexus-oss
pkgver=${_version}.${_patch}
-pkgrel=1
+pkgrel=2
pkgdesc='Nexus 3 Repository OSS'
arch=('any')
url='http://nexus.sonatype.org'
depends=('jre8-openjdk-headless')
-provides=('nexus-oss')
+provides=($pkgname)
+backup=("var/lib/$pkgname/etc/nexus.properties")
source=("http://download.sonatype.com/nexus/3/nexus-$_version-$_patch-unix.tar.gz"
"$pkgname"
"$pkgname.install"
+ "$pkgname.properties"
"$pkgname.service"
"$pkgname.sysusers"
"$pkgname.tmpfiles"
@@ -23,7 +25,8 @@ source=("http://download.sonatype.com/nexus/3/nexus-$_version-$_patch-unix.tar.g
sha256sums=(
"542912830cb804bc2cad1dc247d28440ecd14edd36684bf8bd55d6999b5e083f"
"3d2ebc2a796dbdc7e7e3b97e4c3272292169c898776e111f503f0517e434caff"
- "1b5628130205db11429fc26527e38d3cd613f6c00d08cc19d49a6fe9c1a43d06"
+ "182dc7f3c809e1de9a1b205c933302f353ed618ea554fb70bac53f0d368eae0c"
+ "dcdef5614db12f38b3da0b9de1b52fb7fa402af6621a825981c6168a34a6ad9b"
"0fa963f12b4f2d7da4b25cf7027ced34dc73a361e4c8ddc9b939c00faaeb531e"
"77d699b5ccf6387fa2f69df2cd71cdb75b4ffbf46a10110dd6c0e2802783dbef"
"32bfa3f82038f89d2f7140eada1faadf416ae835d5e5cb0573c528398249a63e"
@@ -36,7 +39,6 @@ install=$pkgname.install
package() {
install -dm755 $pkgdir/usr/lib
install -dm750 $pkgdir/var/lib/$pkgname
- install -dm750 $pkgdir/var/lib/$pkgname/log
cp -a $srcdir/nexus-$_version-$_patch $pkgdir/usr/lib/$pkgname
cp -a $srcdir/sonatype-work/nexus3/orient $pkgdir/var/lib/$pkgname
@@ -47,6 +49,8 @@ package() {
LICENSE.txt
popd
+ install -Dm640 $srcdir/$pkgname.properties $pkgdir/var/lib/$pkgname/etc/nexus.properties
+
install -Dm644 $srcdir/nexus-$_version-$_patch/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
install -Dm755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname
install -Dm644 $srcdir/$pkgname.vmoptions $pkgdir/usr/lib/$pkgname/bin/nexus.vmoptions
@@ -54,5 +58,7 @@ package() {
install -Dm644 $pkgname.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
install -Dm644 $pkgname.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
install -m644 pref_jre.cfg $pkgdir/usr/lib/$pkgname/.install4j
+
+ chmod -R o-rwx $pkgdir/var/lib/$pkgname
}
diff --git a/nexus-oss.install b/nexus-oss.install
index d1ca2b75cb82..8289e689b313 100644
--- a/nexus-oss.install
+++ b/nexus-oss.install
@@ -4,6 +4,23 @@ post_install()
chown -R nexus:nexus var/lib/nexus-oss
chmod -R o-rwx var/lib/nexus-oss
systemd-tmpfiles --create nexus-oss.conf
+
+ cat <<EOF
+
+The default URL for this installation is
+
+ http://127.0.0.1:8081/
+
+To change these settings edit the file
+
+ /var/lib/nexus-oss/etc/nexus.properties
+
+Sonatype strongly suggests using the latest Java 8 release version of Java
+available from Oracle. Support for Java 9 has not been verified - DO NOT USE IT.
+
+See https://help.sonatype.com/display/NXRM3/System+Requirements#SystemRequirements-Java
+
+EOF
}
post_upgrade()
@@ -11,9 +28,13 @@ post_upgrade()
systemctl daemon-reload
}
-post_remove()
+pre_remove()
{
systemctl stop nexus-oss
- userdel -r nexus >/dev/null 2>&1
+}
+
+post_remove()
+{
+ systemctl daemon-reload
}
diff --git a/nexus-oss.properties b/nexus-oss.properties
new file mode 100644
index 000000000000..ee3e47276a65
--- /dev/null
+++ b/nexus-oss.properties
@@ -0,0 +1,3 @@
+application-port=8081
+application-host=127.0.0.1
+nexus-context-path=/