summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
-rw-r--r--README.pkg32
-rw-r--r--install30
3 files changed, 67 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cd09f35e831..54e51e48629b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nfsen
pkgver=1.3.8
-pkgrel=17
+pkgrel=18
pkgdesc="Netflow visualisation and investigation tool"
arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/nfsen"
@@ -23,6 +23,7 @@ source=("$url/files/stable/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
'nginx'
'ports.desc'
'profile.sh'
+ 'README.pkg'
'scripts.conf'
'service'
'tmpfiles')
@@ -46,11 +47,13 @@ package() {
install -Dm644 "$srcdir/nfsen.conf" "$pkgdir/etc/nfsen/nfsen.conf"
install -Dm644 "$srcdir/ports.desc" "$pkgdir/etc/nfsen/ports.desc"
install -Dm644 "$srcdir/nginx" "$pkgdir/usr/share/doc/$pkgname/vhost-nginx.conf"
+ install -Dm644 "$srcdir/README.pkg" "$pkgdir/usr/share/doc/$pkgname/README.pkg"
install -Dm755 "$srcdir/profile.sh" "$pkgdir/etc/profile.d/nfsen.sh"
install -Dm644 "$srcdir/scripts.conf" "$pkgdir/etc/$pkgname/scripts.conf"
install -Dm755 "$srcdir/create_top_directions" "$pkgdir/opt/$pkgname/bin/create_top_directions"
install -Dm755 "$srcdir/create_top_protocols" "$pkgdir/opt/$pkgname/bin/create_top_protocols"
}
+
md5sums=('fc45b3f44a66c2ed65d1269e479c2414'
'7ce142a55af2e18d5db8e419dcc85d3d'
'106f4e354e42d44e64d24d7e16ca8b4a'
@@ -58,6 +61,7 @@ md5sums=('fc45b3f44a66c2ed65d1269e479c2414'
'e8ffd8c767aca866050d679b609a0db9'
'69d219f123963071f89f3d55cda489d9'
'ad1b4a004dacd0508033fcfca763a2fe'
+ '22b95f9cb8f2cf3aa340d2c468a0fafd'
'ba000ec98e02b4baec2afd9aa5f52854'
'69898397995d35b1d53d6a61b16b24a8'
'd60d7334fb00e85ea3230f059ae660aa')
diff --git a/README.pkg b/README.pkg
new file mode 100644
index 000000000000..179d5d00d93e
--- /dev/null
+++ b/README.pkg
@@ -0,0 +1,32 @@
+#
+# README.pkg
+#
+
+To complete the installation, run:
+ cd /usr/share/webapps/nfsen
+ su -c "./install.pl /etc/nfsen/nfsen.conf"
+
+If you edited /etc/nfsen.conf you also need to run:
+ cd /usr/share/webapps/nfsen
+ su -c "./install.pl /etc/nfsen/nfsen.conf"
+
+If you want to use the nginx to access the web, run:
+ sudo pacman -S nginx php-fpm
+ Edit /etc/php/php.ini:
+ Remove comment from ";extension=sockets.so" string
+ Set up virtualhost in nginx
+ An example of the setting for nginx is in the file /usr/share/doc/nfsen/vhost-nginx.conf
+ And run:
+ sudo systemctl start nginx php-fpm
+
+If you are using a web server Apache you know what to do :)
+
+
+To build a profile by protocols, run:
+ sudo create_top_protocols --consumers 8 --divide-up-down --profile-name top_8_protocols
+
+To build a profile in the directions, run:
+ sudo create_top_directions --consumers 10 --divide-up-down --profile-name top_10_directions
+ WARNING!!! - Required file /etc/nfsen/asnum.desc
+
+# End:
diff --git a/install b/install
index ec78574a1148..d3cfe543cadc 100644
--- a/install
+++ b/install
@@ -26,10 +26,40 @@ post_install() {
note ""
note "If you are using a web server Apache you know what to do :)"
note ""
+ note ""
+ note "To build a profile by protocols, run:"
+ note " sudo create_top_protocols --consumers 8 --divide-up-down --profile-name top_8_protocols"
+ note ""
+ note "To build a profile in the directions, run:"
+ note " sudo create_top_directions --consumers 10 --divide-up-down --profile-name top_10_directions"
+ note ""
}
post_upgrade() {
note "To complete the update, run:"
note " cd /usr/share/webapps/nfsen"
note " su -c "./install.pl /etc/nfsen/nfsen.conf""
+ note ""
+ note "If you edited /etc/nfsen.conf you also need to run:"
+ note " cd /usr/share/webapps/nfsen"
+ note " su -c "./install.pl /etc/nfsen/nfsen.conf""
+ note ""
+ note "If you want to use the nginx to access the web, run:"
+ note " sudo pacman -S nginx php-fpm"
+ note " Edit /etc/php/php.ini:"
+ note " Remove comment from ";extension=sockets.so" string"
+ note " Set up virtualhost in nginx"
+ note " An example of the setting for nginx is in the file /usr/share/doc/nfsen/vhost-nginx.conf "
+ note " And run:"
+ note " sudo systemctl start nginx php-fpm"
+ note ""
+ note "If you are using a web server Apache you know what to do :)"
+ note ""
+ note ""
+ note "To build a profile by protocols, run:"
+ note " sudo create_top_protocols --consumers 8 --divide-up-down --profile-name top_8_protocols"
+ note ""
+ note "To build a profile in the directions, run:"
+ note " sudo create_top_directions --consumers 10 --divide-up-down --profile-name top_10_directions"
+ note ""
}