summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 985afc36e933..5efdc83f4be6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,15 +3,14 @@ pkgbase = nftables-fullcone
pkgver = 1.0.5
pkgrel = 1
epoch = 1
- url = https://github.com/fullcone-nat-nftables/
+ url = https://netfilter.org/projects/nftables/
install = nftables.install
arch = x86_64
license = GPL2
makedepends = asciidoc
makedepends = python
- makedepends = git
depends = libmnl
- depends = libnftnl-fullcone
+ depends = libnftnl
depends = gmp
depends = readline
depends = ncurses
@@ -20,12 +19,16 @@ pkgbase = nftables-fullcone
provides = nftables
conflicts = nftables
backup = etc/nftables.conf
- source = nftables-fullcone::git+https://github.com/fullcone-nat-nftables/nftables-1.0.5-with-fullcone.git
+ source = https://netfilter.org/projects/nftables/files/nftables-1.0.5.tar.bz2
+ source = https://netfilter.org/projects/nftables/files/nftables-1.0.5.tar.bz2.sig
source = nftables.conf
source = nftables.service
+ source = https://github.com/wongsyrone/lede-1/raw/master/package/network/utils/nftables/patches/999-01-nftables-add-fullcone-expression-support.patch
validpgpkeys = 37D964ACC04981C75500FB9BD55D978A8A1420E4
+ sha256sums = 8d1b4b18393af43698d10baa25d2b9b6397969beecac7816c35dd0714e4de50a
sha256sums = SKIP
sha256sums = 2aff88019097d21dbfa4713f5b54c184751c86376e458b683f8d90f3abd232a8
sha256sums = deffeef36fe658867dd9203ec13dec85047a6d224ea63334dcf60db97e1809ea
+ sha256sums = f9ac245a057187000f609761dab57b155dba3ff46ad278375a54cf2ec7b6eaa1
pkgname = nftables-fullcone
diff --git a/PKGBUILD b/PKGBUILD
index b5e14a414623..0c07440f3370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Contributor: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
+# Maintainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
pkgname=nftables-fullcone
_pkgname=nftables
@@ -7,25 +7,28 @@ pkgver=1.0.5
pkgrel=1
pkgdesc='Netfilter tables userspace tools (with fullcone patch)'
arch=('x86_64')
-url='https://github.com/fullcone-nat-nftables/'
+url='https://netfilter.org/projects/nftables/'
license=('GPL2')
-depends=('libmnl' 'libnftnl-fullcone' 'gmp' 'readline' 'ncurses' 'jansson')
+depends=('libmnl' 'libnftnl' 'gmp' 'readline' 'ncurses' 'jansson')
optdepends=('python: Python bindings')
-makedepends=('asciidoc' 'python' 'git')
+makedepends=('asciidoc' 'python')
backup=('etc/nftables.conf')
provides=('nftables')
conflicts=('nftables')
validpgpkeys=('37D964ACC04981C75500FB9BD55D978A8A1420E4') # Netfilter Core Team
-source=("$pkgname::git+https://github.com/fullcone-nat-nftables/nftables-$pkgver-with-fullcone.git"
+source=("https://netfilter.org/projects/nftables/files/nftables-$pkgver.tar.bz2"{,.sig}
'nftables.conf'
- 'nftables.service')
+ 'nftables.service'
+ 'https://github.com/wongsyrone/lede-1/raw/master/package/network/utils/nftables/patches/999-01-nftables-add-fullcone-expression-support.patch')
install=nftables.install
-sha256sums=('SKIP'
+sha256sums=('8d1b4b18393af43698d10baa25d2b9b6397969beecac7816c35dd0714e4de50a'
+ 'SKIP'
'2aff88019097d21dbfa4713f5b54c184751c86376e458b683f8d90f3abd232a8'
- 'deffeef36fe658867dd9203ec13dec85047a6d224ea63334dcf60db97e1809ea')
+ 'deffeef36fe658867dd9203ec13dec85047a6d224ea63334dcf60db97e1809ea'
+ 'f9ac245a057187000f609761dab57b155dba3ff46ad278375a54cf2ec7b6eaa1')
prepare() {
- cd $pkgname
+ cd $_pkgname-$pkgver
# apply patch from the source array (should be a pacman feature)
local src
for src in "${source[@]}"; do
@@ -39,7 +42,7 @@ prepare() {
}
build() {
- cd $pkgname
+ cd $_pkgname-$pkgver
autoreconf -fi #FIXME: To remove with 01.patch
./configure \
--prefix=/usr \
@@ -52,7 +55,7 @@ build() {
}
package() {
- pushd $pkgname
+ pushd $_pkgname-$pkgver
make DESTDIR="$pkgdir" install
popd
# basic safe firewall config