summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
-rw-r--r--functional.patch12
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e707682a3c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 23 01:55:28 UTC 2018
+pkgbase = nfusr-git
+ pkgdesc = nfusr is a userspace FUSE client for accessing NFSv3 servers based on libnfs.
+ pkgver = r.
+ pkgrel = 1
+ url = https://github.com/facebookincubator/nfusr
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libnfs
+ provides = nfusr
+ conflicts = nfusr
+
+pkgname = nfusr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c473ac59b70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: François Garillot <francois[@]garillot.net>
+
+pkgname=nfusr-git
+pkgver=r.
+pkgrel=1
+pkgdesc="nfusr is a userspace FUSE client for accessing NFSv3 servers based on libnfs."
+license=('BSD')
+url='https://github.com/facebookincubator/nfusr'
+arch=('i686' 'x86_64')
+provides=('nfusr')
+conflicts=('nfusr')
+depends=('libnfs')
+makedepends=('git')
+
+_gitroot="git://github.com/facebookincubator/nfusr.git"
+_gitname="nfusr"
+
+pkgver() {
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/$pkgname-build
+ ./bootstrap
+}
+
+prepare() {
+ cd $srcdir
+ msg "Connecting to the GIT server...."
+ if [[ -d $srcdir/$_gitname ]] ; then
+ cd $_gitname
+ git checkout master
+ git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ rm -rf $srcdir/$pkgname-build
+ git clone $srcdir/$_gitname $srcdir/$pkgname-build
+ cd $srcdir/$pkgname-build
+ patch -Np1 -i "${srcdir}/../functional.patch"
+}
+
+package() {
+ cd $srcdir/$pkgname-build/
+ ./configure
+ make
+ make DESTDIR="$pkgdir" install
+}
diff --git a/functional.patch b/functional.patch
new file mode 100644
index 000000000000..f6715562ff42
--- /dev/null
+++ b/functional.patch
@@ -0,0 +1,12 @@
+diff --git a/ClientStats.h b/ClientStats.h
+index 2533bf6..1fde607 100644
+--- a/ClientStats.h
++++ b/ClientStats.h
+@@ -11,6 +11,7 @@
+ #include <condition_variable>
+ #include <thread>
+ #include <vector>
++#include <functional>
+
+ #include "fuse_optype.h"
+ #include "logger.h"