summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1c4a6da2f66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nginx-config-formatter-git
+ pkgdesc = nginx config file formatter/beautifier written in Python.
+ pkgver = 6df60552ddb39c4b1ea7118e067961733a261f49
+ pkgrel = 1
+ url = https://github.com/1connect/nginx-config-formatter
+ arch = any
+ license = Apache 2.0
+ depends = python
+ source = nginx-config-formatter-git::git+https://github.com/1connect/nginx-config-formatter
+ sha256sums = SKIP
+
+pkgname = nginx-config-formatter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1909a877b11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=nginx-config-formatter-git
+pkgver=6df60552ddb39c4b1ea7118e067961733a261f49
+pkgrel=1
+pkgdesc="nginx config file formatter/beautifier written in Python. "
+depends=('python')
+license=('Apache 2.0')
+arch=('any')
+url="https://github.com/1connect/nginx-config-formatter"
+source=($pkgname::git+$url)
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 nginxfmt.py "$pkgdir/usr/bin/nginxfmt.py"
+}