summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eba37ce69021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = nginx-http3
+ pkgdesc = Nginx with Cloudflare's http3 path on the top of quiche
+ pkgver = 1.16
+ pkgrel = 1
+ url = https://github.com/cloudflare/quiche/tree/master/extras/nginx
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ makedepends = go
+ makedepends = perl
+ makedepends = ninja
+ makedepends = rust
+ provides = nginx
+ conflicts = nginx
+ conflicts = nginx-unstable
+ conflicts = nginx-svn
+ conflicts = nginx-devel
+ conflicts = nginx-custom-dev
+ conflicts = nginx-full
+ conflicts = nginx-libressl
+ source = https://nginx.org/download/nginx-1.16.1.tar.gz
+ source = git+https://github.com/cloudflare/quiche.git
+ sha256sums = f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b
+ sha256sums = SKIP
+
+pkgname = nginx-http3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33662f5545b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..673433ac9835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=nginx-http3
+pkgver=1.16
+pkgrel=1
+provides=('nginx')
+conflicts=('nginx' 'nginx-unstable' 'nginx-svn' 'nginx-devel' 'nginx-custom-dev' 'nginx-full' 'nginx-libressl')
+pkgdesc="Nginx with Cloudflare's http3 path on the top of quiche"
+arch=('any')
+makedepends=('git' 'cmake' 'make' 'gcc' 'go' 'perl' 'ninja' 'rust')
+depends=()
+url="https://github.com/cloudflare/quiche/tree/master/extras/nginx"
+license=('GPL3')
+source=(
+ "https://nginx.org/download/nginx-$pkgver.$pkgrel.tar.gz"
+ 'git+https://github.com/cloudflare/quiche.git'
+)
+sha256sums=(
+ 'f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b'
+ 'SKIP'
+)
+
+package() {
+ tar xzvf nginx-$pkgver.$pkgrel.tar.gz
+ cd quiche
+ git submodule update --init --recursive
+ cd ../nginx-$pkgver.$pkgrel
+ patch -p01 < ../quiche/extras/nginx/nginx-$pkgver.patch
+ ./configure \
+ --prefix=/etc/nginx \
+ --with-http_ssl_module \
+ --with-http_v2_module \
+ --with-http_v3_module \
+ --with-openssl=../quiche/deps/boringssl \
+ --with-quiche=../quiche
+ make
+ make DESTDIR="$pkgdir/" install
+ cd "$pkgdir/"
+ mkdir usr
+ mv etc/nginx/sbin usr/
+}