summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD43
3 files changed, 29 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12d68d170baf..225c7fcdd824 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = nginx-mainline-mod-http-xslt-filter
- pkgdesc = HTTP XSLT module for the Nginx web server
- pkgver = 1.13.12
+ pkgdesc = Transform nginx XML responses using XSLT stylesheets
+ pkgver = 1.25.3
pkgrel = 1
- url = https://nginx.org
- arch = i686
+ url = https://nginx.org/en/docs/http/ngx_http_xslt_module.html
arch = x86_64
- arch = armv7h
- arch = aarch64
- license = custom
+ license = BSD-2-Clause
+ makedepends = nginx-mainline-src=1.25.3
depends = nginx-mainline
+ depends = libxml2
depends = libxslt
- source = http://nginx.org/download/nginx-1.13.12.tar.gz
- sha256sums = fb92f5602cdb8d3ab1ad47dbeca151b185d62eedb67d347bbe9d79c1438c85de
pkgname = nginx-mainline-mod-http-xslt-filter
-
diff --git a/.gitignore b/.gitignore
index 9b5ba7ef40f4..21c2f1539bd7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+*~
*.tar.gz
*.pkg.tar*
src/
diff --git a/PKGBUILD b/PKGBUILD
index 31537f89722a..920f08ceb42a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-# Maintainer: Sergey Shatunov <me@prok.pw>
+# Maintainer: Repentinus <aur at repentinus dot eu>
+# SPDX-License-Identifier: CC0-1.0
-pkgname=nginx-mainline-mod-http-xslt-filter
-pkgver=1.13.12
+pkgname='nginx-mainline-mod-http-xslt-filter'
+pkgver=1.25.3
pkgrel=1
+pkgdesc='Transform nginx XML responses using XSLT stylesheets'
+arch=('x86_64')
+url='https://nginx.org/en/docs/http/ngx_http_xslt_module.html'
+license=('BSD-2-Clause')
+depends=('nginx-mainline' 'libxml2' 'libxslt')
+makedepends=("nginx-mainline-src=$pkgver")
-_modname="${pkgname#nginx-mainline-mod-}"
-
-pkgdesc='HTTP XSLT module for the Nginx web server'
-arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-depends=('nginx-mainline' 'libxslt')
-url="https://nginx.org"
-license=('custom')
-
-source=(http://nginx.org/download/nginx-$pkgver.tar.gz)
-sha256sums=('fb92f5602cdb8d3ab1ad47dbeca151b185d62eedb67d347bbe9d79c1438c85de')
+prepare() {
+ cp -r /usr/src/nginx/ ./
+}
build() {
- cd "$srcdir"/nginx-$pkgver
- opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
- IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
- ./configure "${opts[@]}" --with-http_xslt_module=dynamic
+ cd 'nginx'
+ _options=$(nginx -V |&
+ sed -nE 's/^configure arguments: ([^\n]*)$/\1/p' |
+ sed -nE 's/([^'"'"' \t\n]+('"'"'([^'"'"'\]|\\'"'"'?)*'"'"'|"([^"\\]|\\"?)*")?) ?/\1\n/gp')
+ xargs ./configure --with-http_xslt_module=dynamic <<< ${_options}
make modules
}
package() {
- cd "$srcdir"/nginx-$pkgver/objs
- for mod in *.so; do
- install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
- done
+ cd 'nginx/objs'
+ install -Dm644 -t "$pkgdir/usr/lib/nginx/modules/$f" *.so
+ install -dm755 "$pkgdir/usr/share/licenses/"
+ ln -s '/usr/share/licenses/nginx/' "$pkgdir/usr/share/licenses/$pkgname"
}