summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 166833332d15..cd0ba8ac6323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-http-xslt-filter
pkgdesc = HTTP XSLT module for the Nginx web server
pkgver = 1.13.3
- pkgrel = 1
+ pkgrel = 2
url = https://nginx.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e3d1416fd58b..6894523af296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nginx-mainline-mod-http-xslt-filter
pkgver=1.13.3
-pkgrel=1
+pkgrel=2
_modname="${pkgname#nginx-mainline-mod-}"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
@@ -18,7 +18,9 @@ sha256sums=('5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72')
build() {
cd "$srcdir"/nginx-$_nginxver
- ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --with-http_xslt_module=dynamic
+ opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
+ IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
+ ./configure "${opts[@]}" --with-http_xslt_module=dynamic
make modules
}