summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5471caabe7ce..67e6b4b3e0a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = nginx-mainline-mod-rtmp
pkgdesc = Module for mainline nginx that adds RTMP support
- pkgver = 1.1.11
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = https://github.com/arut/nginx-rtmp-module
arch = i686
arch = x86_64
license = BSD
depends = nginx-mainline
- source = http://nginx.org/download/nginx-1.13.2.tar.gz
- source = http://nginx.org/download/nginx-1.13.2.tar.gz.asc
- source = https://github.com/arut/nginx-rtmp-module/archive/v1.1.11.tar.gz
+ source = http://nginx.org/download/nginx-1.13.3.tar.gz
+ source = http://nginx.org/download/nginx-1.13.3.tar.gz.asc
+ source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.0.tar.gz
validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = 5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 71e8a0b42a41d1cb5ab1b9a8793f0e479e31fa9b59c4c6f5665df41cebf09e2b
+ sha256sums = a8026f5ade30b178a06f12c46dff053cfe12256016ad465a46646183086b16b0
pkgname = nginx-mainline-mod-rtmp
diff --git a/PKGBUILD b/PKGBUILD
index 13fbb4af58c8..0aa9ca6dc9f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Trevor Bergeron <aur@sec.gd>
pkgname=nginx-mainline-mod-rtmp
-pkgver=1.1.11
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
_modname="nginx-rtmp-module"
_nginxver="$(/bin/nginx -v 2>&1 | grep -Eo '([[:digit:]]|\.)+')"
@@ -18,14 +18,18 @@ source=(
http://nginx.org/download/nginx-$_nginxver.tar.gz.asc
https://github.com/arut/$_modname/archive/v$pkgver.tar.gz
)
-sha256sums=('SKIP'
+sha256sums=('5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72'
'SKIP'
- '71e8a0b42a41d1cb5ab1b9a8793f0e479e31fa9b59c4c6f5665df41cebf09e2b')
+ 'a8026f5ade30b178a06f12c46dff053cfe12256016ad465a46646183086b16b0')
validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8')
build() {
cd "$srcdir"/nginx-$_nginxver
- ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-$pkgver
+ #./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-$pkgver
+ # Cribbed from aur/nginx-mainline-mod-http-xslt-filter by Sergey Shatunov
+ opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@')
+ IFS=$'\n' opts=( $(xargs -n1 <<< "$opts") )
+ ./configure "${opts[@]}" --add-dynamic-module=../$_modname-$pkgver
make modules
}