summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD55
2 files changed, 34 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5340fe5526..3868121de7aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = nginx-mainline-mod-vts
pkgdesc = Nginx virtual host traffic status module (module for mainline nginx)
- pkgver = 0.1.18
- pkgrel = 27
+ pkgver = 0.2.2
+ pkgrel = 2
url = https://github.com/vozlt/nginx-module-vts
- arch = i686
arch = x86_64
- license = BSD
- depends = nginx-mainline=1.19.8
- source = https://nginx.org/download/nginx-1.19.8.tar.gz
- source = nginx-mainline-mod-vts-0.1.18.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v0.1.18.tar.gz
- sha256sums = 308919b1a1359315a8066578472f998f14cb32af8de605a3743acca834348b05
- sha256sums = 17ea41d4083f6d1ab1ab83dad9160eeca66867abe16c5a0421f85a39d7c84b65
+ license = BSD-2-Clause
+ makedepends = nginx-mainline-src
+ depends = glibc
+ depends = nginx-mainline
+ source = nginx-module-vts-0.2.2.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v0.2.2.tar.gz
+ b2sums = 07c24eb62feeb145705ef07dc08feaa06b6b68f80b08e43ff8435bcd1ddbce2ce2d9adffd33efe635678eb787e39d9532f5fb0c22cedd2cb58445b2df14f96f5
pkgname = nginx-mainline-mod-vts
diff --git a/PKGBUILD b/PKGBUILD
index d7b7a74d7d99..47bbfa631ec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,36 @@
-# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
-# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Maintainer: Giovanni Harting <539@idlegandalf.com>
pkgname=nginx-mainline-mod-vts
-pkgver=0.1.18
-pkgrel=27
-
-_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.19.8
-
+pkgver=0.2.2
+pkgrel=2
+_modname=nginx-module-vts
pkgdesc='Nginx virtual host traffic status module (module for mainline nginx)'
-arch=('i686' 'x86_64')
-depends=("nginx-mainline=$_nginxver")
-url="https://github.com/vozlt/nginx-module-vts"
-license=('BSD')
-
-source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz
- $pkgname-$pkgver.tar.gz::https://github.com/vozlt/nginx-module-vts/archive/v$pkgver.tar.gz
-)
-
-sha256sums=('308919b1a1359315a8066578472f998f14cb32af8de605a3743acca834348b05'
- '17ea41d4083f6d1ab1ab83dad9160eeca66867abe16c5a0421f85a39d7c84b65')
+arch=(x86_64)
+depends=(glibc nginx-mainline)
+makedepends=(nginx-mainline-src)
+url='https://github.com/vozlt/nginx-module-vts'
+license=(BSD-2-Clause)
+source=("$_modname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+b2sums=('07c24eb62feeb145705ef07dc08feaa06b6b68f80b08e43ff8435bcd1ddbce2ce2d9adffd33efe635678eb787e39d9532f5fb0c22cedd2cb58445b2df14f96f5')
build() {
- cd "$srcdir"/nginx-$_nginxver
- ./configure --with-compat --add-dynamic-module=../nginx-module-vts-$pkgver
- make modules
+ cp -r /usr/src/nginx .
+
+ cd nginx
+ ./configure --with-compat \
+ --with-cc-opt="$CFLAGS $CPPFLAGS" \
+ --with-ld-opt="$LDFLAGS" \
+ --add-dynamic-module=../$_modname-$pkgver
+ make modules
}
package() {
- install -Dm644 "$srcdir"/nginx-module-vts-$pkgver/LICENSE \
- "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm0644 $_modname-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- cd "$srcdir"/nginx-$_nginxver/objs
- for mod in *.so; do
- install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
- done
+ cd nginx/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
}
+
+# vim:set ts=2 sw=2 et: