summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49a004ddd256
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nginx-mod-slowfs-cache
+ pkgdesc = NGINX module that adds ability to cache static files
+ pkgver = 1.10
+ pkgrel = 1
+ url = http://labs.frickle.com/nginx_ngx_slowfs_cache
+ arch = x86_64
+ license = CUSTOM
+ depends = nginx=1.14.0
+ depends = libutil-linux
+ source = https://nginx.org/download/nginx-1.14.0.tar.gz
+ source = https://nginx.org/download/nginx-1.14.0.tar.gz.asc
+ source = nginx-mod-slowfs-cache-1.10::http://labs.frickle.com/files/ngx_slowfs_cache-1.10.tar.gz
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = 5d15becbf69aba1fe33f8d416d97edd95ea8919ea9ac519eff9bafebb6022cb5
+ sha256sums = SKIP
+ sha256sums = 279e0d8a46d3b1521fd43b3f78bc1c08b263899142a7cc5058c1c0361a92c89c
+
+pkgname = nginx-mod-slowfs-cache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28d7c787db2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id$
+# Maintainer: Martchus <martchus@gmx.net>
+
+pkgname=nginx-mod-slowfs-cache
+pkgver=1.10
+pkgrel=1
+_dirname="ngx_slowfs_cache-${pkgver}"
+_nginxver=1.14.0
+
+pkgdesc='NGINX module that adds ability to cache static files'
+arch=('x86_64')
+depends=("nginx=$_nginxver" "libutil-linux")
+url='http://labs.frickle.com/nginx_ngx_slowfs_cache'
+license=('CUSTOM')
+
+source=(
+ https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
+ "$pkgname-$pkgver::http://labs.frickle.com/files/${_dirname}.tar.gz"
+)
+validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
+sha256sums=('5d15becbf69aba1fe33f8d416d97edd95ea8919ea9ac519eff9bafebb6022cb5'
+ 'SKIP'
+ '279e0d8a46d3b1521fd43b3f78bc1c08b263899142a7cc5058c1c0361a92c89c')
+
+prepare() {
+ cd "$srcdir/$_dirname"
+ echo '
+ if [ "$ngx_module_link" = DYNAMIC ] ; then
+ ngx_module_type=HTTP
+ ngx_module_name=ngx_http_slowfs_module
+ ngx_module_srcs="$ngx_addon_dir/ngx_http_slowfs_module.c"
+ . auto/module
+ fi' >> config
+}
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure --with-compat --add-dynamic-module="../$_dirname"
+ make modules
+}
+
+package() {
+ install -Dm755 "$srcdir/$_dirname/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in ngx_*.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}