summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc5f10a034b8..9ccca0f9e493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,10 @@ _nginx_ver_stable=1.8.0
OPTIONS=(!strip debug) #nchan is still young, in case something goes wrong we want good coredumps
+if [[ ! -z $MTUNE_GENERIC ]]; then
+ CFLAGS="${CFLAGS//mtune=native/mtune=generic}"
+fi
+
_nginx_ver=$_nginx_ver_stable
_pkgname=nginx