summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
2 files changed, 37 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57b6d2eb4f3d..2e60ad672496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Oct 12 20:35:06 UTC 2018
pkgbase = ngp
pkgdesc = ncurses grep tool
- pkgver = 1.3
- pkgrel = 2
+ pkgver = 1.4
+ pkgrel = 1
url = https://github.com/jonathanklee/ngp
arch = i686
arch = x86_64
license = GPL
- makedepends = git
- makedepends = automake
- makedepends = autoconf
makedepends = gcc
- makedepends = make
+ makedepends = cmake
+ depends = git
depends = libconfig
depends = pcre
depends = ncurses
- source = ngp-1.3.tar.gz::https://github.com/jonathanklee/ngp/archive/1.3.tar.gz
- sha256sums = 2b352aa69dc4fbaa8433af0b684120e96737ae7062422eb76d6e8c3ad3ac6bc7
+ source = ngp-1.4.tar.gz::https://github.com/jonathanklee/ngp/archive/1.4.tar.gz
+ sha256sums = 0655c825e12f86ff98dbbd425b38bcd49a565d101028d0454e8e825cb2cd83d4
pkgname = ngp
diff --git a/PKGBUILD b/PKGBUILD
index 4b89605192ca..2656f1d1742e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,49 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: willemw <willemw12@gmail.com>
# Contributor: jklee <klee.jonathan@gmail.com>
set -u
pkgname='ngp'
-pkgver='1.3'
-pkgrel='2'
+pkgver='1.4'
+pkgrel='1'
pkgdesc='ncurses grep tool'
arch=('i686' 'x86_64')
url="https://github.com/jonathanklee/${pkgname}"
license=('GPL')
-depends=('libconfig' 'pcre' 'ncurses')
-makedepends=('git' 'automake' 'autoconf' 'gcc' 'make')
-_verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-#source=(http://github.com/jonathanklee/ngp/archive/${pkgver}.tar.gz)
-sha256sums=('2b352aa69dc4fbaa8433af0b684120e96737ae7062422eb76d6e8c3ad3ac6bc7')
-
-prepare() {
- set -u
- cd "${pkgname}-${pkgver}"
- ./autogen.sh
- ./configure --prefix='/usr'
- set +u
-}
+depends=('git' 'libconfig' 'pcre' 'ncurses')
+makedepends=('gcc' 'cmake')
+_verwatch=("${url}/releases.atom" "\s\+<title>\([0-9][^<]\+\)</title>.*" 'f')
+_srcdir="${pkgname}-${pkgver}"
+source=("${_srcdir}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('0655c825e12f86ff98dbbd425b38bcd49a565d101028d0454e8e825cb2cd83d4')
build() {
set -u
- cd "${pkgname}-${pkgver}"
- make -s -j "$(nproc)"
+ cd "${_srcdir}"
+ if [ -s 'autogen.sh' ]; then
+ if [ ! -s 'Makefile' ]; then
+ ./autogen.sh
+ CFLAGS="${CFLAGS} -Wno-error=stringop-overflow=" \
+ ./configure --prefix='/usr'
+ fi
+ else
+ mkdir -p 'build'
+ cd 'build'
+ if [ ! -s 'Makefile' ]; then
+ CFLAGS=" ${CFLAGS} -Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=return-local-addr" \
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' ..
+ fi
+ fi
+ make -s
set +u
}
package() {
set -u
- cd "${pkgname}-${pkgver}"
+ cd "${_srcdir}"
+ if [ ! -s 'autogen.sh' ]; then
+ cd 'build'
+ fi
make DESTDIR="${pkgdir}" install
set +u
}