summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--spdlog_fix.patch14
3 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2b69c13f929..96e3f5552d62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,8 +22,10 @@ pkgbase = nheko
depends = mtxclient
source = nheko-0.6.4.tar.gz::https://github.com/Nheko-Reborn/nheko/archive/v0.6.4.tar.gz
source = 0001-Fix-deprecated-function-call-issues-with-Qt-5.13.patch
+ source = spdlog_fix.patch
sha512sums = 782673a3ae642029307517798e5be96cf0473cd4261af891988a35dfeb5e2e724d2c034407f62addd2e15973d287d11c6590d70cca739c705354cb0151536470
sha512sums = a20e5a3a152a22525bc1a0563f210bc8ed4f4d988342f20e1960b9530fdc0ca90539847719bbc9abf7802a0cd4af99f41b84641cd0bb5881dc1a9d160e224c2e
+ sha512sums = e0c9992e561d3e8ef3d5bf61032dd48e78b38b4a7db3834aa0703c6a9f0761803e46a9209d440c07fea767be7aa594ed2cbeed1b188f366bf3c9b17da6e2fed3
pkgname = nheko
diff --git a/PKGBUILD b/PKGBUILD
index f6f4a3e76f6f..e7ec59df0f93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,17 @@ depends=('qt5-multimedia' 'qt5-svg' 'hicolor-icon-theme' 'lmdb' 'cmark' 'mtxclie
makedepends=('cmake' 'boost' 'qt5-tools' 'nlohmann-json' 'lmdbxx' 'spdlog' 'tweeny'
'fmt') # https://bugs.archlinux.org/task/63907
source=("$pkgname-$pkgver.tar.gz::https://github.com/Nheko-Reborn/nheko/archive/v$pkgver.tar.gz"
- "0001-Fix-deprecated-function-call-issues-with-Qt-5.13.patch")
+ "0001-Fix-deprecated-function-call-issues-with-Qt-5.13.patch"
+ "spdlog_fix.patch")
sha512sums=('782673a3ae642029307517798e5be96cf0473cd4261af891988a35dfeb5e2e724d2c034407f62addd2e15973d287d11c6590d70cca739c705354cb0151536470'
- 'a20e5a3a152a22525bc1a0563f210bc8ed4f4d988342f20e1960b9530fdc0ca90539847719bbc9abf7802a0cd4af99f41b84641cd0bb5881dc1a9d160e224c2e')
+ 'a20e5a3a152a22525bc1a0563f210bc8ed4f4d988342f20e1960b9530fdc0ca90539847719bbc9abf7802a0cd4af99f41b84641cd0bb5881dc1a9d160e224c2e'
+ 'e0c9992e561d3e8ef3d5bf61032dd48e78b38b4a7db3834aa0703c6a9f0761803e46a9209d440c07fea767be7aa594ed2cbeed1b188f366bf3c9b17da6e2fed3')
prepare() {
mkdir -p build
cd $pkgname-$pkgver
patch -Np1 < ../0001-Fix-deprecated-function-call-issues-with-Qt-5.13.patch
+ patch -Np1 < ../spdlog_fix.patch
}
build() {
diff --git a/spdlog_fix.patch b/spdlog_fix.patch
new file mode 100644
index 000000000000..900543ddd04e
--- /dev/null
+++ b/spdlog_fix.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fda60b7..8493e8f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -399,7 +399,8 @@ set(COMMON_LIBS
+ Qt5::Svg
+ Qt5::Concurrent
+ Qt5::Multimedia
+- nlohmann_json::nlohmann_json)
++ nlohmann_json::nlohmann_json
++ spdlog::spdlog)
+
+ if(APPVEYOR_BUILD)
+ set(NHEKO_LIBS ${COMMON_LIBS} lmdb)