summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b42f6d0a7c6..6a5ab3a62407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,9 @@ pkgdesc="Nimf is a lightweight, fast and extensible input method framework."
arch=('any')
url="https://github.com/hamonikr/nimf"
license=('LGPL3')
-depends=(gtk3
+depends=(
+ 'glibc'
+ 'gtk3'
'glib2'
'libhangul-git'
'libappindicator-gtk3'
@@ -43,7 +45,21 @@ pkgver() {
rm -rf ../../nimf
}
+post_install() {
+ echo "Compiling schemas..."
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ echo "Running ldconfig..."
+ ldconfig
+ echo "Updating GTK icon cache..."
+ gtk-update-icon-cache
+ echo "Updating immodules cache..."
+ gtk-query-immodules-3.0 --update-cache
+ gtk-query-immodules-2.0 --update-cache
+}
+post_upgrade() {
+ post_install $1
+}
build() {
cd "$srcdir/nimf"
./autogen.sh --prefix=/usr