summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore7
-rw-r--r--NinFSGUI.install6
-rw-r--r--PKGBUILD37
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b293526b9143
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ninfs
+ pkgdesc = FUSE filesystem Python scripts for Nintendo console files
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/ihaveamac/ninfs
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pycryptodomex
+ makedepends = unzip
+ noextract = ninfs-1.4-src.zip
+ options = !strip
+ source = ninfs-1.4-src.zip::https://github.com/ihaveamac/ninfs/releases/download/v1.4/ninfs-1.4-src.zip
+ sha256sums = 5fdbb1850abea4b9646577dba764832aaa3bf3f0b12b686ed343e5d42a32847d
+
+pkgname = ninfs
+ depends = python>=3.6.1
+ depends = python-pycryptodomex
+ depends = fuse2
+ depends = openssl>=1.1
+
+pkgname = ninfs-gui
+ install = NinFSGUI.install
+ depends = ninfs=1.4-1
+ depends = python-appjar
+ depends = tk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f589136862b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+*/
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!*.install
diff --git a/NinFSGUI.install b/NinFSGUI.install
new file mode 100644
index 000000000000..07afb2ebbafb
--- /dev/null
+++ b/NinFSGUI.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ echo " >> You'll need the respective terminal for your DE for gui to open."
+ echo " >> Mate for example uses xterm to open a terminal=true set .desktop."
+ echo " >> XFCE uses xfce4-terminal."
+ echo " >> Check what does your respective DE uses and install it."
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9623702dc79d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgbase=ninfs
+pkgname=(ninfs ninfs-gui)
+pkgver=1.4
+pkgrel=1
+pkgdesc="FUSE filesystem Python scripts for Nintendo console files"
+arch=($CARCH)
+license=(MIT)
+url='https://github.com/ihaveamac/ninfs'
+makedepends=('python-setuptools' 'python-pycryptodomex' 'unzip')
+options=(!strip)
+source=("${pkgbase}-${pkgver}-src.zip::${url}/releases/download/v${pkgver}/${pkgbase}-${pkgver}-src.zip")
+sha256sums=('5fdbb1850abea4b9646577dba764832aaa3bf3f0b12b686ed343e5d42a32847d')
+noextract=("${pkgbase}-${pkgver}-src.zip")
+
+build() {
+ unzip "${srcdir}/${pkgbase}-${pkgver}-src.zip" -d "${srcdir}/ninfs"
+ cd "${srcdir}/ninfs"
+ python setup.py build
+}
+
+package_ninfs() {
+ depends=("python>=3.6.1" "python-pycryptodomex" "fuse2" "openssl>=1.1")
+ cd "${srcdir}/ninfs"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ rm -f "$pkgdir/usr/bin/ninfs"
+ rm -rf "$pkgdir/usr/share"
+}
+
+package_ninfs-gui() {
+ depends=("ninfs=$pkgver-$pkgrel" "python-appjar" "tk")
+ install="NinFSGUI.install"
+ cd "${srcdir}/ninfs"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ rm -f "$pkgdir/usr/bin/mount_"*
+ rm -rf "$pkgdir/usr/lib"
+ PYTHONPATH="$pkgdir/usr:$PYTHONPATH" python -mninfs --install-desktop-entry "$pkgdir/usr/share"
+}