summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--nix.install27
3 files changed, 15 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a5b3444cab..17c8f27170d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nix
pkgdesc = A purely functional package manager
- pkgver = 2.2.2
- pkgrel = 3
+ pkgver = 2.3.1
+ pkgrel = 1
url = https://nixos.org/nix
install = nix.install
arch = i686
@@ -15,9 +15,9 @@ pkgbase = nix
depends = boost
depends = brotli
depends = editline
- depends = archlinux-nix
- source = https://nixos.org/releases/nix/nix-2.2.2/nix-2.2.2.tar.xz
- sha256sums = f80a1b4f9837a8d33209f0b7769d5038335459ff4303eccf3e9217a9eca8594c
+ optdepends = archlinux-nix: tools to help with setup of Nix
+ source = https://nixos.org/releases/nix/nix-2.3.1/nix-2.3.1.tar.xz
+ sha256sums = bb6578e9f20eebab6d78469ecc59c450ac54f276e5a86a882015d98fecb1bc7b
pkgname = nix
diff --git a/PKGBUILD b/PKGBUILD
index 3160164a708f..fe4657ec6b98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,18 @@
# Contributor: Anders Bennehag
pkgname=nix
-pkgver=2.2.2
-pkgrel=3
+pkgver=2.3.1
+pkgrel=1
pkgdesc="A purely functional package manager"
arch=('i686' 'x86_64' 'armv7h')
url="https://nixos.org/nix"
license=('LGPL')
-depends=('gc' 'libsodium' 'boost' 'brotli' 'editline' 'archlinux-nix')
+depends=('gc' 'libsodium' 'boost' 'brotli' 'editline')
+optdepends=('archlinux-nix: tools to help with setup of Nix')
makedepends=('bzip2' 'openssl')
install=nix.install
source=("https://nixos.org/releases/nix/nix-$pkgver/nix-$pkgver.tar.xz")
-sha256sums=('f80a1b4f9837a8d33209f0b7769d5038335459ff4303eccf3e9217a9eca8594c')
+sha256sums=('bb6578e9f20eebab6d78469ecc59c450ac54f276e5a86a882015d98fecb1bc7b')
prepare() {
cd "$pkgname-$pkgver"
diff --git a/nix.install b/nix.install
index 551b35f1f7c9..e07213e24a29 100644
--- a/nix.install
+++ b/nix.install
@@ -1,13 +1,7 @@
install_info() {
- echo "Nix is installed and configured, and the nix-daemon should be running. To check,"
- echo "you can run:"
- echo
- echo " archlinux-nix status"
- echo
- echo "Each user's environment is setup on login. Alternatively, you can execute the"
- echo "following to avoid having to log back in:"
- echo
- echo " source /etc/profile.d/nix{,-daemon}.sh"
+ echo "Nix is installed but no configuration has been done to make it work."
+ echo "You may wish to install the archlinux-nix package from AUR to help set"
+ echo "things up."
echo
echo "For more information on how to use nix, check out Part III of the Nix Manual:"
echo
@@ -21,29 +15,18 @@ remove_info() {
echo "1. delete /nix folder"
echo " # rm -r /nix"
echo
- echo "2. delete the build users (if any)"
- echo " # archlinux-nix delete-build-group"
- echo
- echo "3. delete the config dir"
+ echo "2. delete the config dir"
echo " # rm -r /etc/nix"
echo
- echo "4. uninstall the archlinux-nix tool"
- echo " pacman -R archlinux-nix"
- echo
- echo "5. you may also want to delete nix-related files from users' home dirs"
+ echo "3. you may also want to delete nix-related files from users' home dirs"
echo " # rm -r /root/.nix-* /home/*/.nix-*"
echo
}
post_install() {
- archlinux-nix bootstrap
install_info
}
-post_upgrade() {
- archlinux-nix bootstrap
-}
-
post_remove() {
remove_info
}