summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 562a12e6fc51..8a00b07e58bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nix
pkgdesc = A purely functional package manager
pkgver = 2.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://nixos.org/nix
install = nix.install
arch = i686
@@ -9,13 +9,12 @@ pkgbase = nix
arch = armv7h
license = LGPL
makedepends = bzip2
- makedepends = gc
makedepends = openssl
depends = gc
depends = libsodium
depends = boost
depends = brotli
- depends = readline
+ depends = editline
source = https://nixos.org/releases/nix/nix-2.2.2/nix-2.2.2.tar.xz
sha256sums = f80a1b4f9837a8d33209f0b7769d5038335459ff4303eccf3e9217a9eca8594c
diff --git a/PKGBUILD b/PKGBUILD
index ac476676a64f..7b68c7a839eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,26 +8,23 @@
pkgname=nix
pkgver=2.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="A purely functional package manager"
arch=('i686' 'x86_64' 'armv7h')
url="https://nixos.org/nix"
license=('LGPL')
-depends=('gc' 'libsodium' 'boost' 'brotli' 'readline')
-makedepends=('bzip2' 'gc' 'openssl')
+depends=('gc' 'libsodium' 'boost' 'brotli' 'editline')
+makedepends=('bzip2' 'openssl')
install=nix.install
source=("https://nixos.org/releases/nix/nix-$pkgver/nix-$pkgver.tar.xz")
sha256sums=('f80a1b4f9837a8d33209f0b7769d5038335459ff4303eccf3e9217a9eca8594c')
-
prepare() {
cd "$pkgname-$pkgver"
}
build () {
cd "$pkgname-$pkgver"
- export EDITLINE_CFLAGS="-DREADLINE"
- export EDITLINE_LIBS="/usr/lib/libreadline.so"
./configure --prefix=/usr \
--libexecdir="/usr/lib/$pkgname" \
--sysconfdir=/etc \