summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a19230654f4b..19fd3b32856b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = nnpack-git
pkgdesc = An acceleration package for neural network computations (git version)
pkgver = r359.1e005b0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Maratyszcza/NNPACK/
- arch = i386
+ arch = i686
arch = x86_64
license = BSD
makedepends = git
@@ -11,8 +11,7 @@ pkgbase = nnpack-git
makedepends = ninja
makedepends = confu2-git
makedepends = python2-peachpy-git
- options = staticlibs
- source = nnpack-git::git+https://github.com/Maratyszcza/NNPACK.git
+ source = git+https://github.com/Maratyszcza/NNPACK.git
sha256sums = SKIP
pkgname = nnpack-git
diff --git a/PKGBUILD b/PKGBUILD
index f1ab047e0899..b36e18d25a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer : Daniel Bermond < gmail-com: danielbermond >
pkgname=nnpack-git
+_srcname=NNPACK
pkgver=r359.1e005b0
-pkgrel=1
+pkgrel=2
pkgdesc='An acceleration package for neural network computations (git version)'
-arch=('i386' 'x86_64')
+arch=('i686' 'x86_64')
url='https://github.com/Maratyszcza/NNPACK/'
license=('BSD')
makedepends=(
@@ -13,30 +14,27 @@ makedepends=(
# AUR:
'confu2-git' 'python2-peachpy-git'
)
-options=('staticlibs')
-source=("$pkgname"::"git+https://github.com/Maratyszcza/NNPACK.git")
+source=('git+https://github.com/Maratyszcza/NNPACK.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, no tags available
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
+ cd "${_srcname}"
confu2 setup
- python2 ./configure.py #--enable-shared # https://github.com/Maratyszcza/NNPACK/issues/56
- sed -i '/cflags[[:space:]]=[[:space:]]/s/$/ -fPIC/' build.ninja # add -fPIC
- sed -i '/cxxflags[[:space:]]=[[:space:]]/s/$/ -fPIC/' build.ninja # add -fPIC
+ python2 configure.py
sed -i '/peachpy[[:space:]]=[[:space:]]python/s/python/python2/' build.ninja # use python2
ninja
}
package() {
- cd "${pkgname}"
+ cd "$_srcname"
# headers
mkdir -p "${pkgdir}/usr/include/nnpack"
@@ -47,5 +45,5 @@ package() {
install -D -m644 lib/libnnpack.a -t "${pkgdir}/usr/lib"
# license
- install -D -m644 LICENSE -t"${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}