summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a7f94d43af4..65365a5bc99e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = nocache
pkgdesc = minimize caching effects
- pkgver = 1.1
+ pkgver = 1.2
pkgrel = 1
url = https://github.com/Feh/nocache
arch = i686
arch = x86_64
license = FreeBSD License
- source = git+https://github.com/Feh/nocache.git#commit=e4e77a48528739188dccbdbd8b4d2d2d49aa0d99
- sha256sums = SKIP
+ source = nocache-1.2.tar.gz::https://github.com/Feh/nocache/archive/refs/tags/v1.2.tar.gz
+ sha256sums = 2f8c6adbc82da4477416e1eaf9d435cf52f602d07064602f433d4ba4ecad5fdd
pkgname = nocache
-
diff --git a/PKGBUILD b/PKGBUILD
index 07e523c5fcdf..6e5f009b5e3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
-# Maintainer: <grawity@gmail.com>
+# Contributor: <grawity@gmail.com>
# Contributor: goll <adrian.goll+aur[at]gmail>
pkgname=nocache
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="minimize caching effects"
arch=(i686 x86_64)
url="https://github.com/Feh/nocache"
license=('FreeBSD License')
-_commit=e4e77a48528739188dccbdbd8b4d2d2d49aa0d99
-source=("git+https://github.com/Feh/nocache.git#commit=$_commit")
-sha256sums=('SKIP')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Feh/nocache/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('2f8c6adbc82da4477416e1eaf9d435cf52f602d07064602f433d4ba4ecad5fdd')
-pkgver() {
- cd "$pkgname"
- git describe | sed "s/^v//; s/-/.r/; s/-/./"
-}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir" install
}