summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore9
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD28
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da303ec463a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nodejs-broccoli-cli
+ pkgdesc = Global CLI for broccoli.js
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://broccolijs.com/
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = broccoli-cli-1.0.0.tgz
+ source = https://registry.npmjs.org/broccoli-cli/-/broccoli-cli-1.0.0.tgz
+ source = LICENSE
+ md5sums = 5b35a2a4187c45f6ea4e74a5f47de0f9
+ md5sums = 196006ee5e61740475b5d1fea5b285a1
+
+pkgname = nodejs-broccoli-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f2913fb1eb5a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# packaging artefacts
+src/
+pkg/
+*.pkg.tar.xz
+*.src.tar.gz
+
+# source archives
+*.tgz
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4ce04998167c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2013 Jo Liss
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11b06934f40c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Micha Alt <micha.tucker at gmail dot com>
+
+_npmname=broccoli-cli
+pkgname=nodejs-$_npmname
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Global CLI for broccoli.js"
+arch=('any')
+url="http://broccolijs.com/"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz
+ 'LICENSE')
+noextract=($_npmname-$pkgver.tgz)
+md5sums=('173465398acd8664a30da24439ae6f08'
+ '4741c206fc73f1a664bdadd0e4cef754')
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}
+