summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d201b7423722..37854a053346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Sep 4 08:31:34 UTC 2017
+# Tue Sep 5 18:53:44 UTC 2017
pkgbase = nodejs-how2
pkgdesc = finds the simplest way to do something in a unix shell. It's like man, but you can query it in natural language:
pkgver = 1.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/santinic/how2
arch = any
license = MIT
depends = nodejs
depends = npm
noextract = how2-1.1.0.tgz
- source = http://registry.npmjs.org/how2/-/how2-1.1.0.tgz
+ source = https://registry.npmjs.org/how2/-/how2-1.1.0.tgz
sha256sums = 96adf72bfa307c5413314afb547179e781f9ef18db6c7233b104da399657478e
pkgname = nodejs-how2
diff --git a/PKGBUILD b/PKGBUILD
index 92a7b02956c4..085eab38dedf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_npmname=how2
pkgname=nodejs-how2
pkgver=1.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="finds the simplest way to do something in a unix shell. It's like man, but you can query it in natural language:"
arch=(any)
url="https://github.com/santinic/how2"
license=(MIT)
depends=('nodejs' 'npm')
-source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
noextract=($_npmname-$pkgver.tgz)
sha256sums=('96adf72bfa307c5413314afb547179e781f9ef18db6c7233b104da399657478e')
@@ -19,5 +19,8 @@ package() {
mkdir -p "$_npmdir"
cd "$_npmdir"
npm install -g --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
- install -Dm644 "how2/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "how2/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Fix NPM racecondition, also known as derp
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
}