summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8369925df6d..cade527241fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Feb 28 08:30:38 UTC 2018
pkgbase = nodejs-jsonlint
pkgdesc = Validate JSON
- pkgver = 1.6.2
- pkgrel = 2
+ pkgver = 1.6.3
+ pkgrel = 1
url = http://zaach.github.com/jsonlint/
arch = any
license = MIT
makedepends = nodejs
depends = nodejs
depends = npm
- noextract = jsonlint-1.6.2.tgz
- source = http://registry.npmjs.org/jsonlint/-/jsonlint-1.6.2.tgz
- md5sums = 4849a84bcf4864bd61c552711979e8cd
+ noextract = jsonlint-1.6.3.tgz
+ source = http://registry.npmjs.org/jsonlint/-/jsonlint-1.6.3.tgz
+ sha256sums = 987f42f0754b7bc0c84967b81fc2b4db0ed2ebe2117ccc5a5faa59e462447723
pkgname = nodejs-jsonlint
diff --git a/PKGBUILD b/PKGBUILD
index 7a94a143effd..298e253a24c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Justin Dray <justin@dray.be>
# Contributor: Florent Peterschmitt
_npmname=jsonlint
-pkgname=nodejs-jsonlint # All lowercase
-pkgver=1.6.2
-pkgrel=2
-pkgdesc="Validate JSON"
+pkgname=nodejs-${_npmname}
+pkgver=1.6.3
+pkgrel=1
+pkgdesc='Validate JSON'
arch=(any)
-url="http://zaach.github.com/jsonlint/"
+url='http://zaach.github.com/jsonlint/'
license=('MIT')
depends=('nodejs'
'npm')
makedepends=('nodejs')
-source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
noextract=($_npmname-$pkgver.tgz)
-md5sums=('4849a84bcf4864bd61c552711979e8cd')
+sha256sums=('987f42f0754b7bc0c84967b81fc2b4db0ed2ebe2117ccc5a5faa59e462447723')
package() {
- cd $srcdir
- local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p $_npmdir
- cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ npm install -g --prefix $pkgdir/usr $_npmname-$pkgver.tgz
+ rmdir $pkgdir/usr/etc
}