summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD25
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8369925df6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nodejs-jsonlint
+ pkgdesc = Validate JSON
+ pkgver = 1.6.2
+ pkgrel = 2
+ url = http://zaach.github.com/jsonlint/
+ arch = any
+ license = MIT
+ makedepends = nodejs
+ depends = nodejs
+ depends = npm
+ noextract = jsonlint-1.6.2.tgz
+ source = http://registry.npmjs.org/jsonlint/-/jsonlint-1.6.2.tgz
+ md5sums = 4849a84bcf4864bd61c552711979e8cd
+
+pkgname = nodejs-jsonlint
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..181b3460e424
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a94a143effd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Florent Peterschmitt
+
+_npmname=jsonlint
+pkgname=nodejs-jsonlint # All lowercase
+pkgver=1.6.2
+pkgrel=2
+pkgdesc="Validate JSON"
+arch=(any)
+url="http://zaach.github.com/jsonlint/"
+license=('MIT')
+depends=('nodejs'
+ 'npm')
+makedepends=('nodejs')
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+md5sums=('4849a84bcf4864bd61c552711979e8cd')
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}