summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21820041c6ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jul 7 13:58:11 UTC 2016
+pkgbase = nodejs-nomnoml-cli
+ pkgdesc = Generates images from nomnoml diagram sources on the command line
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/prantlf/nomnoml-cli
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = nomnoml-cli-0.2.3.tgz
+ source = http://registry.npmjs.org/nomnoml-cli/-/nomnoml-cli-0.2.3.tgz
+ sha1sums = bb0cc08215a71714325e0fe82b5bc5a144f725c9
+
+pkgname = nodejs-nomnoml-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55d85ddb4a07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+_npmname=nomnoml-cli
+_npmver=0.2.3
+pkgname=nodejs-nomnoml-cli
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="Generates images from nomnoml diagram sources on the command line"
+arch=(any)
+url="https://github.com/prantlf/nomnoml-cli"
+license=(MIT)
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(bb0cc08215a71714325e0fe82b5bc5a144f725c9)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+