summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--LICENSE14
-rw-r--r--PKGBUILD10
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef0a4bc797c9..af3edd47d715 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 31 03:53:31 UTC 2016
+# Sun Jan 31 04:01:36 UTC 2016
pkgbase = nodejs-sinopia
pkgdesc = Private npm repository server
pkgver = 1.4.0
@@ -7,15 +7,18 @@ pkgbase = nodejs-sinopia
url = https://github.com/rlidwka/sinopia
install = nodejs-sinopia.install
arch = any
+ license = WTFPL
makedepends = npm
depends = nodejs
noextract = sinopia-1.4.0.tgz
source = http://registry.npmjs.org/sinopia/-/sinopia-1.4.0.tgz
source = sinopia.service
source = nodejs-sinopia.install
+ source = LICENSE
sha1sums = 36bf5209356facbf6cef18fa32274d116043ed24
sha1sums = a96ee3c3407e70a22bef11d42f0f3b393eefc1ae
sha1sums = 9cb284b9f22894a6f2cd465156d9ed9f5c1c8776
+ sha1sums = 337ece375beddfdb7392699fd00eb9b3e823d03f
pkgname = nodejs-sinopia
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ee7d6a54e914
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,14 @@
+ DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+ Version 2, December 2004
+
+ Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>
+
+ Everyone is permitted to copy and distribute verbatim or modified
+ copies of this license document, and changing it is allowed as long
+ as the name is changed.
+
+ DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+ 0. You just DO WHAT THE FUCK YOU WANT TO.
+
diff --git a/PKGBUILD b/PKGBUILD
index ab5d189663be..0152dc2f801c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,19 @@ pkgrel=2
pkgdesc="Private npm repository server"
arch=("any")
url="https://github.com/rlidwka/sinopia"
-license=()
+license=("WTFPL")
depends=("nodejs")
makedepends=("npm")
install=nodejs-sinopia.install
source=("http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz"
"sinopia.service"
- "nodejs-sinopia.install")
+ "nodejs-sinopia.install"
+ "LICENSE")
noextract=("$_npmname-$pkgver.tgz")
sha1sums=("36bf5209356facbf6cef18fa32274d116043ed24"
"a96ee3c3407e70a22bef11d42f0f3b393eefc1ae"
- "9cb284b9f22894a6f2cd465156d9ed9f5c1c8776")
+ "9cb284b9f22894a6f2cd465156d9ed9f5c1c8776"
+ "337ece375beddfdb7392699fd00eb9b3e823d03f")
package() {
cd $srcdir
@@ -28,6 +30,8 @@ package() {
install -Dm644 sinopia.service "$pkgdir/usr/lib/systemd/system/sinopia.service"
install -Dm644 sinopia.service "$pkgdir/usr/lib/systemd/user/sinopia.service"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: