summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfbcdf1173d0..a4509bcc35f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nomad
pkgdesc = A Distributed, Highly Available, Datacenter-Aware Scheduler
- pkgver = 0.10.4
- pkgrel = 2
+ pkgver = 1.1.1
+ pkgrel = 1
url = https://nomadproject.io/
arch = x86_64
arch = aarch64
@@ -16,16 +16,15 @@ pkgbase = nomad
optdepends = rkt: enables rkt driver
backup = etc/nomad/server.conf
backup = etc/nomad/client.conf
- source = https://github.com/hashicorp/nomad/archive/v0.10.4/nomad-0.10.4.tar.gz
+ source = https://github.com/hashicorp/nomad/archive/v1.1.1/nomad-1.1.1.tar.gz
source = nomad-server.service
source = nomad-server.conf
source = nomad-client.service
source = nomad-client.conf
- sha256sums = 8f216520622da094327caa5b6e27e0298bbd68778c7b99f436a16d6391110f99
+ sha256sums = 441d2f50a29568451cb16301a2208c9b744a480ded8c624e789983ee42ed3ea9
sha256sums = 52b0a22c3c0c72c642a8728cb48bd8797f4f6a12990e11bbb2342edcc2a9a206
sha256sums = da475bc4aa3b1493eb62f09e7f99dcc171e8ce6d74df3da30514cfdfe72a5714
sha256sums = 4c8fb7c18c67ca20e3ee07f25cf2f0c82b66c4c173275ae8d643c91cce3c0ceb
sha256sums = ba80943ac42e617627c7e14be402078199ddba8d7e4276d67f0c9f6e6842d4a8
pkgname = nomad
-
diff --git a/PKGBUILD b/PKGBUILD
index 84e4f994b5b2..4f4e530b1ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Maintainer: Radek Podgorny <radek@podgorny.cz>
+# Co-maintainer: Tyler Langlois <ty |at| tjll |dot| net>
pkgname=nomad
-pkgver=0.10.4
-pkgrel=2
+pkgver=1.1.1
+pkgrel=1
pkgdesc="A Distributed, Highly Available, Datacenter-Aware Scheduler"
arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
url="https://nomadproject.io/"
@@ -16,7 +17,7 @@ optdepends=('docker: enables docker driver'
backup=(etc/nomad/{server,client}.conf)
source=(https://github.com/hashicorp/nomad/archive/v$pkgver/$pkgname-$pkgver.tar.gz
nomad-{server,client}.{service,conf})
-sha256sums=('8f216520622da094327caa5b6e27e0298bbd68778c7b99f436a16d6391110f99'
+sha256sums=('441d2f50a29568451cb16301a2208c9b744a480ded8c624e789983ee42ed3ea9'
'52b0a22c3c0c72c642a8728cb48bd8797f4f6a12990e11bbb2342edcc2a9a206'
'da475bc4aa3b1493eb62f09e7f99dcc171e8ce6d74df3da30514cfdfe72a5714'
'4c8fb7c18c67ca20e3ee07f25cf2f0c82b66c4c173275ae8d643c91cce3c0ceb'
@@ -32,8 +33,6 @@ prepare() {
export GOPATH="$srcdir"
export PATH="$GOPATH/bin:$PATH"
- go get golang.org/x/sys/cpu
-
make deps lint-deps
mkdir -p bin
}
@@ -44,8 +43,9 @@ build() {
export PATH="$GOPATH/bin:$PATH"
CGO_ENABLED=1 \
- go build -ldflags '-X main.GitCommit=""' \
- -tags "ui lxc" \
+ go build -trimpath \
+ -ldflags '-X main.GitCommit=""' \
+ -tags "ui release" \
-o bin/nomad
}