summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--container.patch11
-rw-r--r--golang-crypto.patch131
-rw-r--r--lxc-version-check.patch41
5 files changed, 9 insertions, 217 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd46634a183c..928359cdac57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Mar 21 08:22:20 UTC 2019
pkgbase = nomad
pkgdesc = A Distributed, Highly Available, Datacenter-Aware Scheduler
- pkgver = 0.8.7
- pkgrel = 2
+ pkgver = 0.9.0
+ pkgrel = 1
url = https://www.nomadproject.io/
arch = i686
arch = x86_64
@@ -17,22 +15,16 @@ pkgbase = nomad
optdepends = java-runtime-headless
backup = etc/nomad/server.conf
backup = etc/nomad/client.conf
- source = https://github.com/hashicorp/nomad/archive/v0.8.7/nomad-0.8.7.tar.gz
+ source = https://github.com/hashicorp/nomad/archive/v0.9.0/nomad-0.9.0.tar.gz
source = nomad-server.service
source = nomad-server.conf
source = nomad-client.service
source = nomad-client.conf
- source = lxc-version-check.patch
- source = golang-crypto.patch
- source = container.patch
- sha256sums = f74eac627de69190e586358b1956573a0ae1a40d0755ecdee163016949f9c7fe
+ sha256sums = fb6a0afd6895540dd5e18c878421c39e2a2759e90af8eb771c84802d082475df
sha256sums = 52b0a22c3c0c72c642a8728cb48bd8797f4f6a12990e11bbb2342edcc2a9a206
sha256sums = da475bc4aa3b1493eb62f09e7f99dcc171e8ce6d74df3da30514cfdfe72a5714
sha256sums = 4c8fb7c18c67ca20e3ee07f25cf2f0c82b66c4c173275ae8d643c91cce3c0ceb
sha256sums = ba80943ac42e617627c7e14be402078199ddba8d7e4276d67f0c9f6e6842d4a8
- sha256sums = 740cf838f4489b00fab8329c81ba21b1fae02e584d8fac2b5f88eeec76e4e62f
- sha256sums = 75583a195b43d7345449bbac60359bf54661ccbd699386a6e59bb483c6054338
- sha256sums = d7f483250456cb7b92a437661999786b7295628fc09e1a3b0769606902d82ef0
pkgname = nomad
diff --git a/PKGBUILD b/PKGBUILD
index a1119b296d61..ff08dfdd3f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=nomad
-pkgver=0.8.7
-pkgrel=2
+pkgver=0.9.0
+pkgrel=1
pkgdesc="A Distributed, Highly Available, Datacenter-Aware Scheduler"
arch=('i686' 'x86_64')
url="https://www.nomadproject.io/"
@@ -16,18 +16,12 @@ optdepends=(
)
backup=(etc/nomad/{server,client}.conf)
source=(https://github.com/hashicorp/nomad/archive/v$pkgver/$pkgname-$pkgver.tar.gz
- nomad-{server,client}.{service,conf}
- lxc-version-check.patch
- golang-crypto.patch
- container.patch)
-sha256sums=('f74eac627de69190e586358b1956573a0ae1a40d0755ecdee163016949f9c7fe'
+ nomad-{server,client}.{service,conf})
+sha256sums=('fb6a0afd6895540dd5e18c878421c39e2a2759e90af8eb771c84802d082475df'
'52b0a22c3c0c72c642a8728cb48bd8797f4f6a12990e11bbb2342edcc2a9a206'
'da475bc4aa3b1493eb62f09e7f99dcc171e8ce6d74df3da30514cfdfe72a5714'
'4c8fb7c18c67ca20e3ee07f25cf2f0c82b66c4c173275ae8d643c91cce3c0ceb'
- 'ba80943ac42e617627c7e14be402078199ddba8d7e4276d67f0c9f6e6842d4a8'
- '740cf838f4489b00fab8329c81ba21b1fae02e584d8fac2b5f88eeec76e4e62f'
- '75583a195b43d7345449bbac60359bf54661ccbd699386a6e59bb483c6054338'
- 'd7f483250456cb7b92a437661999786b7295628fc09e1a3b0769606902d82ef0')
+ 'ba80943ac42e617627c7e14be402078199ddba8d7e4276d67f0c9f6e6842d4a8')
prepare() {
mkdir -p src/github.com/hashicorp
@@ -49,17 +43,6 @@ prepare() {
make bootstrap
mkdir -p bin
-
- pushd vendor/gopkg.in/lxc/go-lxc.v2
- patch -p1 -i "$srcdir"/lxc-version-check.patch
- popd
-
- pushd vendor/golang.org/x/crypto
- patch -p1 -i "$srcdir"/golang-crypto.patch
- popd
-
- pushd vendor/gopkg.in/lxc/go-lxc.v2
- patch -p0 -i "$srcdir"/container.patch
}
build() {
diff --git a/container.patch b/container.patch
deleted file mode 100644
index 228f3d1af3e8..000000000000
--- a/container.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../../../../../nomad-0.8.7.orig/vendor/gopkg.in/lxc/go-lxc.v2/container.go 2019-03-15 09:59:16.230241650 +0000
-+++ container.go 2019-03-15 10:00:22.343574744 +0000
-@@ -767,7 +767,7 @@
- c.mu.RLock()
- defer c.mu.RUnlock()
-
-- var keys *_Ctype_char
-+ var keys *C.char
-
- if key != nil && len(key) == 1 {
- ckey := C.CString(key[0])
diff --git a/golang-crypto.patch b/golang-crypto.patch
deleted file mode 100644
index 89adda4d81b2..000000000000
--- a/golang-crypto.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From ae8bce0030810cf999bb2b9868ae5c7c58e6343b Mon Sep 17 00:00:00 2001
-From: Andreas Auernhammer <aead@mail.de>
-Date: Mon, 30 Apr 2018 19:54:52 +0200
-Subject: [PATCH] crypto/{blake2b,blake2s,argon2,chacha20poly1305}: replace CPU
- feature detection
-
-This change removes package specific CPU-feature detection code and
-replaces it with x/sys/cpu.
-
-Fixes golang/go#24843
-
-Change-Id: I150dd7b3aeb8eef428c91f9b1df741ceb8a87a24
-Reviewed-on: https://go-review.googlesource.com/110355
-Run-TryBot: Ilya Tocar <ilya.tocar@intel.com>
-TryBot-Result: Gobot Gobot <gobot@golang.org>
-Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
----
- blake2b/blake2bAVX2_amd64.go | 26 ++++-----
- blake2b/blake2bAVX2_amd64.s | 12 -----
- blake2b/blake2b_amd64.go | 7 ++-
- blake2b/blake2b_amd64.s | 9 ----
- 11 files changed, 41 insertions(+), 182 deletions(-)
-
-diff --git a/blake2b/blake2bAVX2_amd64.go b/blake2b/blake2bAVX2_amd64.go
-index 8c41cf6c7..4d31dd0fd 100644
---- a/blake2b/blake2bAVX2_amd64.go
-+++ b/blake2b/blake2bAVX2_amd64.go
-@@ -6,21 +6,14 @@
-
- package blake2b
-
-+import "golang.org/x/sys/cpu"
-+
- func init() {
-- useAVX2 = supportsAVX2()
-- useAVX = supportsAVX()
-- useSSE4 = supportsSSE4()
-+ useAVX2 = cpu.X86.HasAVX2
-+ useAVX = cpu.X86.HasAVX
-+ useSSE4 = cpu.X86.HasSSE41
- }
-
--//go:noescape
--func supportsSSE4() bool
--
--//go:noescape
--func supportsAVX() bool
--
--//go:noescape
--func supportsAVX2() bool
--
- //go:noescape
- func hashBlocksAVX2(h *[8]uint64, c *[2]uint64, flag uint64, blocks []byte)
-
-@@ -31,13 +24,14 @@ func hashBlocksAVX(h *[8]uint64, c *[2]uint64, flag uint64, blocks []byte)
- func hashBlocksSSE4(h *[8]uint64, c *[2]uint64, flag uint64, blocks []byte)
-
- func hashBlocks(h *[8]uint64, c *[2]uint64, flag uint64, blocks []byte) {
-- if useAVX2 {
-+ switch {
-+ case useAVX2:
- hashBlocksAVX2(h, c, flag, blocks)
-- } else if useAVX {
-+ case useAVX:
- hashBlocksAVX(h, c, flag, blocks)
-- } else if useSSE4 {
-+ case useSSE4:
- hashBlocksSSE4(h, c, flag, blocks)
-- } else {
-+ default:
- hashBlocksGeneric(h, c, flag, blocks)
- }
- }
-diff --git a/blake2b/blake2bAVX2_amd64.s b/blake2b/blake2bAVX2_amd64.s
-index 784bce6a9..5593b1b3d 100644
---- a/blake2b/blake2bAVX2_amd64.s
-+++ b/blake2b/blake2bAVX2_amd64.s
-@@ -748,15 +748,3 @@ noinc:
-
- MOVQ BP, SP
- RET
--
--// func supportsAVX2() bool
--TEXT ·supportsAVX2(SB), 4, $0-1
-- MOVQ runtime·support_avx2(SB), AX
-- MOVB AX, ret+0(FP)
-- RET
--
--// func supportsAVX() bool
--TEXT ·supportsAVX(SB), 4, $0-1
-- MOVQ runtime·support_avx(SB), AX
-- MOVB AX, ret+0(FP)
-- RET
-diff --git a/blake2b/blake2b_amd64.go b/blake2b/blake2b_amd64.go
-index 2ab7c30fc..30e2fcd58 100644
---- a/blake2b/blake2b_amd64.go
-+++ b/blake2b/blake2b_amd64.go
-@@ -6,13 +6,12 @@
-
- package blake2b
-
-+import "golang.org/x/sys/cpu"
-+
- func init() {
-- useSSE4 = supportsSSE4()
-+ useSSE4 = cpu.X86.HasSSE41
- }
-
--//go:noescape
--func supportsSSE4() bool
--
- //go:noescape
- func hashBlocksSSE4(h *[8]uint64, c *[2]uint64, flag uint64, blocks []byte)
-
-diff --git a/blake2b/blake2b_amd64.s b/blake2b/blake2b_amd64.s
-index 64530740b..578e947b3 100644
---- a/blake2b/blake2b_amd64.s
-+++ b/blake2b/blake2b_amd64.s
-@@ -279,12 +279,3 @@ noinc:
-
- MOVQ BP, SP
- RET
--
--// func supportsSSE4() bool
--TEXT ·supportsSSE4(SB), 4, $0-1
-- MOVL $1, AX
-- CPUID
-- SHRL $19, CX // Bit 19 indicates SSE4 support
-- ANDL $1, CX // CX != 0 if support SSE4
-- MOVB CX, ret+0(FP)
-- RET
diff --git a/lxc-version-check.patch b/lxc-version-check.patch
deleted file mode 100644
index b190b04bf719..000000000000
--- a/lxc-version-check.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/lxc-binding.c b/lxc-binding.c
-index 4592b68..d26b9ef 100644
---- a/lxc-binding.c
-+++ b/lxc-binding.c
-@@ -15,11 +15,6 @@
-
- #include "lxc-binding.h"
-
--#define VERSION_AT_LEAST(major, minor, micro) \
-- (!(major > LXC_VERSION_MAJOR || \
-- major == LXC_VERSION_MAJOR && minor > LXC_VERSION_MINOR || \
-- major == LXC_VERSION_MAJOR && minor == LXC_VERSION_MINOR && micro > LXC_VERSION_MICRO))
--
- bool go_lxc_defined(struct lxc_container *c) {
- return c->is_defined(c);
- }
-diff --git a/lxc-binding.h b/lxc-binding.h
-index f7ccd84..ed1829a 100644
---- a/lxc-binding.h
-+++ b/lxc-binding.h
-@@ -2,6 +2,11 @@
- // Use of this source code is governed by a LGPLv2.1
- // license that can be found in the LICENSE file.
-
-+#define VERSION_AT_LEAST(major, minor, micro) \
-+ ((LXC_DEVEL == 1) || (!(major > LXC_VERSION_MAJOR || \
-+ major == LXC_VERSION_MAJOR && minor > LXC_VERSION_MINOR || \
-+ major == LXC_VERSION_MAJOR && minor == LXC_VERSION_MINOR && micro > LXC_VERSION_MICRO)))
-+
- extern bool go_lxc_add_device_node(struct lxc_container *c, const char *src_path, const char *dest_path);
- extern void go_lxc_clear_config(struct lxc_container *c);
- extern bool go_lxc_clear_config_item(struct lxc_container *c, const char *key);
-@@ -72,7 +77,7 @@ extern bool go_lxc_restore(struct lxc_container *c, char *directory, bool verbos
- * we don't want to have to pass all the arguments in to let conditional
- * compilation handle things, but the call will still fail
- */
--#if LXC_VERSION_MAJOR != 2
-+#if !VERSION_AT_LEAST(2, 0, 0)
- struct migrate_opts {
- char *directory;
- bool verbose;