summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc1944f6b994..6a3ccdf0f7b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nomino-bin
pkgdesc = Batch rename utility for developers
- pkgver = 1.3.1
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/yaa110/nomino
arch = x86_64
@@ -8,12 +8,12 @@ pkgbase = nomino-bin
license = MIT
depends = gcc-libs
depends = glibc
- provides = nomino
+ provides = nomino=1.3.2
conflicts = nomino
- source = nomino-1.3.1::https://github.com/yaa110/nomino/releases/download/1.3.1/nomino-linux-64bit
+ source = nomino-1.3.2::https://github.com/yaa110/nomino/releases/download/1.3.2/nomino-linux-64bit
source = LICENSE-MIT::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-MIT
source = LICENSE-APACHE::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-APACHE
- sha256sums = 7bceb645e53acb5dff82b4e1cec9e5d568336326b8c89e4870fdbe62dc80547d
+ sha256sums = 989882d693a4fe6add4a140b52a51b1e5079919ef76faa93863270397c2b2c35
sha256sums = c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f
sha256sums = 0beb66d48e2a5702f0f1d8c8f62cce5877410c85eed400952db3d58a759935ef
diff --git a/PKGBUILD b/PKGBUILD
index d01407abf086..d640ccff4b7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,22 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: yaa110 <yaa110@gmail.com>
pkgname=nomino-bin
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc='Batch rename utility for developers'
arch=('x86_64')
url="https://github.com/yaa110/nomino"
license=('Apache' 'MIT')
depends=('gcc-libs' 'glibc')
-provides=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}::https://github.com/yaa110/nomino/releases/download/1.3.1/nomino-linux-64bit"
+source=("${pkgname%-bin}-${pkgver}::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux-64bit"
"LICENSE-MIT::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-MIT"
"LICENSE-APACHE::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-APACHE")
-sha256sums=('7bceb645e53acb5dff82b4e1cec9e5d568336326b8c89e4870fdbe62dc80547d'
+sha256sums=('989882d693a4fe6add4a140b52a51b1e5079919ef76faa93863270397c2b2c35'
'c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f'
'0beb66d48e2a5702f0f1d8c8f62cce5877410c85eed400952db3d58a759935ef')
package() {
- install -Dm0755 "${srcdir}/${pkgname%-bin}-${pkgver}" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- install -Dm0755 -d "${pkgdir}/usr/bin"
- ln -s "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm0755 "${srcdir}/${pkgname%-bin}-${pkgver}" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file