summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD78
2 files changed, 41 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b76b2aa67ec..a1fa613ae849 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nordic-theme-git
- pkgdesc = Dark Gtk3.20+ theme created using the awesome Nord color pallete.
- pkgver = v2.1.0.r20.gacdd7e4
+ pkgdesc = Nord-derived themes for GTK and other platforms
+ pkgver = 2.1.0.r42.g81c9976
pkgrel = 1
url = https://github.com/EliverLara/Nordic
arch = any
@@ -13,7 +13,7 @@ pkgbase = nordic-theme-git
optdepends = cantarell-fonts: tertiary font face defined
provides = nordic-theme
conflicts = nordic-theme
- source = Nordic::git+https://github.com/EliverLara/Nordic.git
+ source = nordic-theme-git::git+https://github.com/EliverLara/Nordic
sha256sums = SKIP
pkgname = nordic-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 03122f95b15f..56ccefab820a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,71 @@
-# Maintainer: Tony Lambiris <tony@libpcap.net>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Tony Lambiris <tony@libpcap.net>
pkgname=nordic-theme-git
-_pkgname=Nordic
-pkgver=v2.1.0.r20.gacdd7e4
+pkgver=2.1.0.r42.g81c9976
pkgrel=1
-pkgdesc="Dark Gtk3.20+ theme created using the awesome Nord color pallete."
+pkgdesc="Nord-derived themes for GTK and other platforms"
arch=("any")
-url="https://github.com/EliverLara/${_pkgname}"
+url="https://github.com/EliverLara/Nordic"
license=('GPL')
makedepends=('git' 'inkscape' 'optipng')
-optdepends=('ttf-roboto: primary font face defined'
- 'ttf-ubuntu-font-family: secondary font face defined'
- 'cantarell-fonts: tertiary font face defined')
+optdepends=(
+ 'ttf-roboto: primary font face defined'
+ 'ttf-ubuntu-font-family: secondary font face defined'
+ 'cantarell-fonts: tertiary font face defined')
conflicts=('nordic-theme')
provides=('nordic-theme')
-source=("${_pkgname}::git+https://github.com/EliverLara/${_pkgname}.git")
+source=("$pkgname::git+$url")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "$pkgname"
export THEME_FONT_FACE="${THEME_FONT_FACE:-Roboto}"
export THEME_FONT_SIZE="${THEME_FONT_SIZE:-10}"
- msg2 "To customize the font and size for gnome-shell, build this package"
- msg2 "with the variables below set to the desired font family and size"
- msg2 "- THEME_FONT_FACE (default font family is Roboto)"
- msg2 "- THEME_FONT_SIZE (default font point size is 10)"
- msg2 ""
- msg2 "Continuing build in 5 seconds..."; sleep 5
+ echo "To customize the font and size for gnome-shell, build this package"
+ echo "with the variables below set to the desired font family and size"
+ echo "- THEME_FONT_FACE (default font family is Roboto)"
+ echo "- THEME_FONT_SIZE (default font point size is 10)"
+ echo ""
+ echo "Continuing build in 5 seconds..."; sleep 5
- msg2 "Rendering assets, please wait"
- pushd gtk-2.0
- while read $line; do echo -n "."; done < \
- <(./render-assets.sh 2>/dev/null); echo
- popd
+ echo "Rendering assets, please wait"
+ ( cd gtk-2.0
+ while read $line; do echo -n "."; done < \
+ <(./render-assets.sh 2>/dev/null); echo )
- pushd src
- while read $line; do echo -n "."; done < \
- <(./render-gtk3-assets.py 2>/dev/null; \
- ./render-gtk3-assets-hidpi.py 2>/dev/null; \
- ./render-wm-assets-hidpi.py 2>/dev/null; \
- ./render-wm-assets.py 2>/dev/null); echo
- popd
- msg2 "Done!"
+ # pushd src
+ ( cd src
+ while read $line; do echo -n "."; done < \
+ <(./render-gtk3-assets.py 2>/dev/null; \
+ ./render-gtk3-assets-hidpi.py 2>/dev/null; \
+ ./render-wm-assets-hidpi.py 2>/dev/null; \
+ ./render-wm-assets.py 2>/dev/null); echo )
+ echo "Done!"
- msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
- msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+ echo "Setting gnome-shell font face to ${THEME_FONT_FACE}"
+ echo "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
if [ "${THEME_FONT_FACE}" != "Roboto" ]; then
sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
- "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ "${srcdir}/$pkgname/gnome-shell/gnome-shell.css"
fi
if [ "${THEME_FONT_SIZE}" != "10" ]; then
sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
- "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ "${srcdir}/$pkgname/gnome-shell/gnome-shell.css"
fi
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- mkdir -p "${pkgdir}/usr/share/themes/${_pkgname}"
- cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}/"
+ cd "$pkgname"
+ find assets cinnamon gnome-shell gtk* metacity-1 xfwm4 \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/Nordic/{}" \;
}