aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--README.md14
3 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dbee5b878f4..9c8aad69359a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nordlayer
pkgdesc = Proprietary VPN client for linux
- pkgver = 2.6.4
+ pkgver = 2.6.5
pkgrel = 0
url = https://nordlayer.com
install = nordlayer.install
@@ -12,7 +12,7 @@ pkgbase = nordlayer
replaces = nordvpnteams-bin
options = !strip
options = !emptydirs
- source_x86_64 = https://downloads.nordlayer.com/linux/latest/debian/pool/main/nordlayer_2.6.4_amd64.deb
- sha512sums_x86_64 = 2f11fd0fd98f9a627fbcde60832f8dbf5d5478bc9bf93b71ca99d26dd89b46e28ae080bcbe0db2a6e3c7ca097e77d753d6627ffdae318aedcf716566d15b30dc
+ source_x86_64 = https://downloads.nordlayer.com/linux/latest/debian/pool/main/nordlayer_2.6.5_amd64.deb
+ sha512sums_x86_64 = 5d71c7acf0a6a6f96689d4cbffc2fc3b64079463727a0ffd9f17bfbf5936907abbf0b8ad3bd2edf9f2e3efd70474fa64d699dbb8a9d402de56a8efb5243ea7ad
pkgname = nordlayer
diff --git a/PKGBUILD b/PKGBUILD
index cb8b65a36f7b..fc64ab3b31da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Deividas Gedgaudas <sidicer at gmail dot com>
pkgname=nordlayer
-pkgver=2.6.4
+pkgver=2.6.5
pkgrel=0
pkgdesc="Proprietary VPN client for linux"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ depends=('bash')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source_x86_64=("https://downloads.nordlayer.com/linux/latest/debian/pool/main/${pkgname}_${pkgver}_amd64.deb")
-sha512sums_x86_64=('2f11fd0fd98f9a627fbcde60832f8dbf5d5478bc9bf93b71ca99d26dd89b46e28ae080bcbe0db2a6e3c7ca097e77d753d6627ffdae318aedcf716566d15b30dc')
+sha512sums_x86_64=('5d71c7acf0a6a6f96689d4cbffc2fc3b64079463727a0ffd9f17bfbf5936907abbf0b8ad3bd2edf9f2e3efd70474fa64d699dbb8a9d402de56a8efb5243ea7ad')
package(){
# Extract package data
diff --git a/README.md b/README.md
index 0be93d7f99ab..5443881bf497 100644
--- a/README.md
+++ b/README.md
@@ -1,5 +1,15 @@
# [Nordlayer](https://nordlayer.com) VPN package for Linux (esp [ArchLinux](https://archlinux.org/))
-[![AUR version](https://img.shields.io/aur/version/nordlayer)](https://aur.archlinux.org/packages/nordlayer) [![Nordlayer version](https://img.shields.io/badge/nordlayer-2.6.3-green)](https://nordlayer.com/download/linux/)
+[![AUR version](https://img.shields.io/aur/version/nordlayer)](https://aur.archlinux.org/packages/nordlayer) [![Nordlayer version](https://img.shields.io/badge/nordlayer-2.6.5-green)](https://nordlayer.com/download/linux/)
+
+### Hotfix (Version 2.6.5) released by Nordlayer
+The new version should not break `nordlayer.db`
+
+If you're still facing issues afterwards - repeat 2.6.4 version fix
+```sh
+rm /var/lib/nordlayer/nordlayer.db
+systemctl restart nordlayer
+nordlayer login
+```
### Upgrade from 2.6.3 to 2.6.4 BREAKS nordlayer.db
```sh
@@ -31,5 +41,5 @@ git clone https://github.com/Sidicer/nordlayer.git
cd nordlayer
makepkg -si
# If 'makepkg -si' fails to install automatically:
-sudo pacman -U nordlayer-2.6.4-0-x86_64.pkg.tar.zst
+sudo pacman -U nordlayer-2.6.5-0-x86_64.pkg.tar.zst
```