summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD37
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1146e29267f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = noson-app-git
+ pkgdesc = SONOS controller for Linux platforms
+ pkgver = 3.6.0.r2.g2ff2fad
+ pkgrel = 1
+ url = https://janbar.github.io/noson-app
+ arch = x86_64
+ groups = base-devel
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = cmake
+ depends = qt5-base
+ depends = qt5-quickcontrols2
+ depends = qt5-graphicaleffects
+ depends = qt5-svg
+ provides = noson-app
+ conflicts = noson-app
+ source = git+git://github.com/janbar/noson-app.git
+ sha1sums = SKIP
+
+pkgname = noson-app-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..953192b26947
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Package files
+*.pkg.tar.xz
+
+# Sources
+noson-app
+pkg
+src
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbd86043d54a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dennis Twardowsky <aur@devpty.de>
+_pkgname=noson-app
+pkgname="${_pkgname}-git"
+pkgver=3.6.0.r5.g70fcd71
+pkgrel=1
+pkgdesc="SONOS controller for Linux platforms"
+arch=('x86_64')
+url="https://janbar.github.io/noson-app"
+license=('GPL3')
+groups=('base-devel')
+depends=('cmake' 'qt5-base' 'qt5-quickcontrols2' 'qt5-graphicaleffects' 'qt5-svg')
+makedepends=('cmake' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+git://github.com/janbar/noson-app.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+ cmake "$srcdir/${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/lib
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
+}
+